Phantom curve sometimes appears when zoomed in

The curve in the top left in this screenshot is a mirage:

It’s actually the curve I’m selecting at the bottom left, sort of mirrored and projected onto the screen because I’m heavily zoomed in.

I can’t really reproduce this reliably, but it usually happens when:

  1. You zoom in on a small part of a very long curve
  2. You activate a tool that requires curve selection
  3. You get the selection popup where you happen to click

I think the last part is very important, because at least this last time, I wasn’t able to reproduce it if I clicked somewhere that didn’t activate the popup (as I’m writing this, I’m able to reproduce the phantom curve any number of times until I change the camera angle).

Rhino has very few graphical glitches for me, but this is one of them. Anyone else experience this?

Hi Robert -

I can’t make that happen here, no.
This curve is 6346 units long, I’ve zoomed in, and get the selection pop-up:

If you have a file in which you can reliably reproduce this, please post it so that we can take a look.
-wim

1 Like

Managed to capture this one just now:

GIF 11.09.2020 11-26-52

Note the extra, mirrored fillet edge preview flying into the screen in the end…

1 Like

I’ve seen this as well - my guess is, if you turn on the camera (F6) you will see that it is very small - eye point very close to the target.

-Pascal