Mirroring curves not previewing in correct place


#1

Mirror line taken at midpoint of straight curve. Curve (a trimmed circle) displays in the wrong position (yellow curve).

The points are in the correct place. When command is excecuted the mirrored curve appears in the correct position.

Rhino 6


#2

You are very far from the origin in Y - 143,000+ units. I can repeat this at that distance under certain circumstances - I actually get no preview at all in the file at a certain point. Nearer to the origin it’s OK.

In the file below at about 130,000 units in X, mirroring the green arc around the center of the box (line) gets a preview. The red arc, 10 units further to the left, doesn’t.

MirrorNoPreview.3dm (309.2 KB)

–Mitch


#3

Is this just a Rhino 6 problem? I have never had trouble with this in the past.


#4

Yes, it works fine in V5. @stevebaer This appears to be another side effect of “GPU Tessellation”. If I turn it off here the preview is correct.

Bug filed: https://mcneel.myjetbrains.com/youtrack/issue/RH-44199

@benjamin can you post the file with the elements in your image? I can’t make it happen here in Y, only in X.

–Mitch


#5

If it helps

mirror-curve-test.3dm (278.5 KB)


(Pascal Golay) #6

Got that. thanks.
https://mcneel.myjetbrains.com/youtrack/issue/RH-44201

-Pascal


(Dale Fugier) #7

Hi @benjamin,

So far, I am unable to reproduce the in correct preview image that you’ve reported. My test box even has a lame gpu (Intel).

Can you click Help > System Information and copy/paste the results into a reply. Also, the sample file you posted doesn’t seem to have the geometry you’ve presented in your original post. Is that something that is available?

Thanks,

– Dale


#8

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 8.1 (Physical RAM: 16Gb)

Quadro K1100M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

mirror-curve-test2.3dm (227.6 KB)

Now the mirror preview doesn’t display at all.


(Dale Fugier) #9

Thanks @benjamin, I’ve logged your info on the YouTrack item.

– Dale


(Jack Gaumer) #10

I (as well as a few co-workers) have had the same issue with Rhino 6. We’re getting some mis-located previews with various transformation commands: rotate, move, scale1d, etc…

If I can provide information on my machine/install/files that would help out with this, please let me know.


#11

@dale here’s mine -

Note this is happening on two computers, one with a 980 Ti, the other (below) a 780.

@pascal - I think you duplicated my yt entry…

Rhino 6 SR2 2018-2-7 (Rhino 6, 6.2.18038.4101, Git hash:master @ a558313bc402d40d17bdf4500977c08ab6e465e4)

Windows 8.1 (Physical RAM: 16Gb)

GeForce GTX 780/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


#12

Any news on this?


#13

According to youtrack, it does not appear to have been worked on yet…
https://mcneel.myjetbrains.com/youtrack/issue/RH-44199