Bug report: print icons to pdf

Let me please report a bug here.

When trying to print a text object (in case a simple page title block) from a layout to pdf the icons do not print. See below for images.
The same thing happens for different fonts.

It would be wonderful if this could be fixed.

The following is shown on the layout:
layout

The following is printed as pdf:

Are the icons images?
Are they placed on the layout space or shown in a detail?
The fastest workaround is to set to raster the printer output but this would convert everything to a big image (if I use pdf I would that the output is raster for images and vectors for lines and arcs).
Another way could be (if the first answer is yes) to convert the icons to vectors.
Or, if the icons are on the layout space, to put them on a detail setted to rendered.
Sorry but I am answering out of office (by phone) and cannot try directly on rhino.

Hi Lucio Zadra,
Thanks for the quick reply.
These icons are part of the font (Arial), so they are glyphs.
These icons are placed in the layout space.
It would be wonderful if you could have a look at this when you’re in the office again and let me know what you find.

Hi David,
I think that it’s a problem with the character map stored with the pdf (the symbols aren’t recognized).
Well, the workaround I suggest is to Explode the symbols so they become lines and arcs (the only thing is that you have to make some hatches to reproduce the black fill).
Remember to group the exploded symbol so you can move and scale without loosing pieces around.
Hope that this can solve for you.

Hi Lucio Zadra,
Thanks for the workaround suggestion. I think a workaround should however not be nessecary here.

I have check with word and there the icons get stored within when printing to pdf.
Does this mean that this bug is present in the Rhino PDF printer?

Could be… to be sure, you could try to print with the Window’s PDF printer (assuming you are using win X).
Another try is to print from a normal viewport to see if the problem is caused by layout.
We have to say that special characters are always a problem to manage cause they are connected to the “style” installed in your sistem; PDF should solve saving the character style into the file but not all the printers works in the same way…

As I look through the Arial font using Windows Character Map, I do not see these glyphs.

Same here, I thought it was my Arial collection that was missing something…
So could be that the David’s Arial Font isn’t a standard one?

That’s what I suspect.

Previously I copied in character from another pdf document. That does not seem to work.
Now I tried to copy in the characters from the Windows Character Map directly. Didn’t now this software exists. That works!
Thanks for the help!

1 Like

Can you please post a small 3dm file containing only a text string with these glyphs in it?
Thanks

Hereby the 3dm file with the simple title block on the single layout page.

It seems like I know a bit more about the problem now.
It looks like the character from the Windows Character Map actually work when printing. These have the unicodes values that start with an U+E and have 3 more numbers/letters.
However it also seems like the characters with the unicodes that start with U+1F and 3 more letters/numbers don’t work and are also not shown in the Windows Character Map. Could this be?

title block.3dm (2.5 MB)

There is some debate that the PDF function library we are using may not support these special characters. We will contact them with this example.

As a work around, I just tried PDF995. It’s a free PDF “printer” I’ve used for years, and one we recommended before we wrote our own tool.
It works fine and supports these special characters.
title block.pdf (8.1 KB)

https://mcneel.myjetbrains.com/youtrack/issue/RH-59681

Wonderful, please let me know about the outcome.

Thanks for the suggestion.