Rhino PDF not working! Help!

I have an urgent drawing to get out and rhino pdf is not printing the pdf correctly. When I open it in adobe acrobat to send to my plotter, it says that the file is damaged. It worked nicely for the last few days and now this. Please help, what do I do! I have to get this printed today! Boss is waiting and this makes me look like a fool. :frowning: And the other PDF printers (bullzip and CutePDF) won’t print the pictures I have in the layout (they print as pure black squares with strange streaks through them).


Hello - probably best to send the Rhino file to


Are you printing as vector or raster?


Hi Pascal, I would but it’s confidential drawings and I signed a contract prohibiting me from sharing them with anyone. It doesn’t matter if I do raster or vector…same problem.

Have you tried the SR8 release candidate? There were several printing related issues I fixed in SR8

Just updated. Will run a test print now and report back.

Just ran a test print using rhino pdf, and same issue. When I open the pdf in adobe acrobat, I get this:

“An error exists on this page. Acrobat man not display the page correctly. Please contact the person who created the pdf to correct the problem.”

And the pdf is missing all the dimensions, which leaves me to assume this is a dimensions problem!

Note that when I’m printing from rhino pdf, see that dimensions are on, but note the strange lines running off the page in the printer preview window. And again, the resulting pdf prints without the dimensions and gives me the warning in the post above. And it’s the same whether I set to print raster or vector.

Is there dimensions setting I need to change to fix this??

So I did a little test and deleted all the dimensions, then printed. And now the PDF opens without issue.

So evidently, this is a dimensions related problem! And I suspect it has something to do with the dimensions history feature, because at one point, I had to move my detail window to better position the drawings on the layout, and I got the warning that I was breaking history with dimensions.

What do I do without having to spend an hour re-dimensioning everything?

You shouldn’t have to do anything. Would it be possible to send me a file with this problem so I can try and repeat this? I only need a file with a single dimension that exhibits the problem so you don’t have to send any confidential stuff.

I uploaded the stripped down file for your review using your upload link.

Hi Steve, I just uploaded the file to the link Pascal provided above. Let me know if you’re able to view that.

I got the file thanks. I’ll take a look

1 Like

Any luck?

Also, any idea why rhino pdf printing from model space is soo slow? Print a simple pdf using rhino pdf takes upto 2 minutes sometimes.

I was able to repeat the bug that you are seeing. I haven’t made any progress beyond that yet

This is due to the rendered details getting drawn as a series of tiles to generate higher resolution images. We are working on this issue.