PDF Print Quality

Yes, it is free.

I’ve been able to generate the PDF from your file, here you have it in case you need it. I’m going now to bed, it is very late here in Spain. I hope you can solve your problem.
Counter Seychellian.pdf (11.0 MB)

No, there are two versions the commercial one and the WIP. Use 5.4, it is the last one.

I will keep fiddling with it.

OK I will DL it. Perhaps this will explain the missing print dialogue. Duerma bien! :sleeping:

OK so Rhino does not give an option to scale print to “Viewport/Extents/Window” in the Layouts print dialogue.

This is the case in all versions as you can see from jespizua’s screengrab…


He is using the latest commercial version.

This is a screen grab on my computer from the model space print dialogue…

OK, so that is one mystery solved, the print dialog is different for model and layout space. I did not appreciate that…


1 Like

Have you tried changing the layout detail size itself to A1 (do not activate the layout detail, but click on the edge and open the properties inspector), then printing it at a reduced scale to fit A3 size?

Yes I have, in fact I addressed that in a previous post. I have also corrected all the file issues brought up by @jespizua (moved model to 0,0,0 and removed floating objects deep in model space and layouts) and still no cigar.

I also found this little setting in the printer settings for the Acrobat printer driver that I installed …

It defaults to 300dpi and the problem is that if I increase higher than that (to 600dpi or 1200dpi) Rhino immediately crashes.

Unfortunately these dpi control settings do not apply to OSX’s native PDF printer. In fact I have no idea how you control the dpi quality of PDF’s created with OSX’s default PDF printer…

I have attached the cleaned up file just in case anyone else wants to have a bash at getting it to print properly.

Counter.3dm (17.6 MB)

Good morning @Seychellian!
I’m on the metro now, in 20 min I’ll arrive to my studio and will take a look at your file, will print it to PDF.

1 Like

Hi jespizua,

So… I have managed to print them at 600dpi and the lines look much better. It turns out those dpi setting also apply to Mac OSX PDF printer.

The problem is that when I increase the dpi above 300dpi Rhino doesn’t like it at all and most of the time crashes.

The only way I was able to get it to print was by printing each page individually. Even then I had to do the second page 3 times before it actually printed. So it’s not exactly the perfect solution.

The other thing I have now noticed is that the hatch pattern in the logo is doing some weird stuff…

It’s small enough that you may not notice it when you print, but it strikes me as there is something not quite right about the whole thing.

HI Seychellian,

I’ve got news. I opened your file in my studio computer, which happens to be a macbook pro late 2013 just like yours, and I’m having the same issue as you are having. I’ve also opened the fixed file I sent you before and it is not printing properly, so this my be system related.

On my macbook pro I have 10.12.6, and at home I have a macpro 2008 with nvidia 660Ti on 10.11.6…
Don’t know what else could be…

@dan, do you have any idea what is going on?

1 Like

I have tried again today, clean file, just a box and layout.
I tried different print quality, etc., all the same result: WIREFRAME = Perfect, AnyShadingMethod = Pixelated (it has that 90’s Lucas Art feel when you zoom in).
My specs are: Sierra 10.12.6, Rhino 5.4 (5E407).
I am going to try the Windows version now…

1 Like

But that’s expected. If you use a rendered viewport, your output will be pixels not vectors. Another thing is the output resolution, which shouldn’t be as low as we are getting in this case.

1 Like

The same thing is happening in Rhino Windows.

There should be a setting to print images with better quality to PDF on shaded detail views.

1 Like

To be honest, I’m having trouble following along. I’m testing with the model from this post. I am getting the same results as the PDF in this post.