Paint Glossyness is not working in latest patch Rhino6

Hi Rhino Users

Anyone else have a problem with the new release and the paint glossyness… I have set the glossy to about 50% and it is still super glossy, these are models used in other scenes with the same lighting etc. but the gloss is very shiny and when I turn it down the slider is not predictable… goes from matte to gloss only in a tiny sweet spot the rest is all matte or all gloss and right at the end goes back to matte… I think there has been an oops here.

Any help will be appreciated, I am close to finishing a multi- year project and all the models are now different… Over a hundred multi-part, multi colour models…
bit of a nightmare if I change them all now and then have to change them all back when this is all fixed up.

Thanks for your responses ahead of time.
Kind regards

Hi - you mention “latest patch” and “new release” - was this working differently for you in a previous version, and if yes, which version was that?
Please run the Rhino SystemInfo command and post the result here. Also, please post a simple 3dm file that shows the issue.

Hi :slight_smile: Thanks for the quick response.

The release that worked was the one just before this one:

6 SR16
(6.16.19169.11231, 06/18/2019)

Here is the system info:

Rhino 6 SR16 2019-6-18 (Rhino 6, 6.16.19169.11231, Git hash:master @ 8c6ac16b099ae942efd28d85ea242eb24346c1a0)
License type: Commercial, build 2019-06-18
License details: Stand-Alone

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: USER-PC

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 4-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.39

Secondary graphics devices.
Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 12-27-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-17-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19169.11231
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19169.11231
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19169.11231
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.16.19169.11231
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19169.11231
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - thanks for that information!
I can’t say that I’ve heard other experiencing this issue. Could you post a simple model that behaves badly?

I just tested this same 6.16 build and Paint glossiness is working in both Rendered mode and Raytraced mode. Which are you in when it doesn’t work? Select just a few objects that show the issue and use Export to create a 3dm file with just those to upload here as well please.

Hi… Thanks for the rapid fire responses guys. I think I need to explain more clearly about how the glossiness has changed, it still works but works differently, so the previous values are rendered differently, making all the work I did before look different to the work I am doing now. So though I am using the same models they are all very glossy now, and the slider seems to only have a small area where the matt and gloss are adjusted… before that on the slider it is all matt and after that all gloss… like the slider has shrunk in the wash. I attach a pic of the model in one scene and in the latest scene, same lighting and everything… I cannot upload any models due to an NDA… but you can see the difference in the models, and if you test the slider you will see that the model goes from matt to gloss only in a very small area of the slider. I hope with my restricted information you can still help? Maybe just looking at the older code for that slider and the new one and comparing will clear it up… or it might be my graphics card… but I doubt that since it worked great and then directly after the update everything got a gloss.

Thanks again guys.!
The original slightly matt of one of the models:

Same model, same settings:

Probably the best quick test if you have machines with the different builds is to make a sphere with a semi gloss paint material in the previous build using sun and studio lighting and render it using Cycles…then open the same scene in the latest build and render that exact scene and compare the glossiness?

Anyway, just wanted to say that I am always impressed with Rhino, since i’ts first beta release the program and the support have been incredible.
Kind regards

What display mode are you in? Is this problem in Rendered mode or Raytraced for you? I think it is Raytraced looking at the small images posted but want to be sure. 6.16 is a service release candidate build as well… if you grab the 6.15 service release off of our download page > Uninstall Rhino 6.16 and then install 6.15, is the result what you expect on your model?

Options > Updates and Statistics can be used to set whether you want service release candidates or only service releases.

Hi Brian.

The problem is in raytraced mode and then Cycles capture… I will give that a try.

Thanks again.

Hi again.

Rolling back to 6.15 service release fixed the problem right away. Thanks so much guys… all the models are back to the perfect sheen.

Thanks so much for all your help.
Kind regards

Of course, that’s probably not going to do much good for you in the long run. If there is a change somewhere that you see in a specific workflow but that goes unnoticed in other workflows, chances are that this change will remain in the builds in the future and you are stuck on 6.15. So, if you want this looked at, you will have to provide a sample that is not working for you in 6.16.

I got it @wim Filed as… I didn’t mock up a test until I knew the mode.



1 Like

I pushed some tweaks that hopefully gives better glossiness control. It appears the values were being raised unnecessarily many times to the power of two, resulting in much higher gloss.

RH-53403 is fixed in the latest Service Release Candidate

Hi guys

That is fantastic… Thank you so much for all your hard work!

Kind regards