"oversized" icons after update


#1

Hi there,

I just updated to the newest version of Rhino5. Since the update Rhino’a appearance has changed. Everything looks “oversized”. Before the update everything looked crisp sharp and now the resolution seems messed up.
I tried to reinstall from the dvd and everything looked fine again until I did the update again.
I tried to “scale down” the icons but nothing helps.
Does anyone have the same problem?
Any ideas what to do?

Currently working on parallels with windows 8.

Cheers,
Raoul


(John Brock) #2

I suspect you have your Windows display settings need to be adjusted.
Set your screen resolution and text scaling at recommended settings and see if that helps.

That aside, running Windows Rhino under Parallels is not a supported platform.


#3

What does this mean in practical terms? Rhino works fine for a lot of people under Parallels on Macs, especially with a second, higher performance video card.


#4

I already checked but it just can’t be cause other softwares run just fine. I am switching back and forth (by uninstlling and reinstalling) and nothing changes with my resolution except that Rhino’s overall appearance is altered.

I know that this method is not the perfect way to do it but until now I never had any problems with parallels and Rhino. It always worked just fine.

Cheers for your help.
R


(John Brock) #5

It means you’re on your own.
We can’t troubleshoot problems specific to issues with virtualization.
Specifically, virtualization in general and Parallels specifically, is slow, has inadequate OpenGL support, and is generally glitchy for most people.
If you’re willing to put up with that then go for it.
We certainly won’t stop you, but we won’t spend any effort trying to duplicate and fix problems that are specific to Parallels.


(John Brock) #6

As a last resort, run SetDpiAwareness and disable it. Then SR14 should act like it did before.


#7

Thanks for the hint.
Nothing changes.

I ll skip this update and hope that the next one won’t act like SR14…

Have a good one.
R


(John Brock) #8

There will not be another Rhino V5 service release.
V5 development is finished.
After disabling SetDpiAwareness, did you close and restart Rhino?


#9

Yes, I even restarted windows.

Good to know cause then I ll probably switch to the mac version at some point.


(John Brock) #10

That’s fine as long as you don’t need any major third-party plug-ins for RDK based rendering features.


#11

That will be another topic. Currently using Vray with that dongle…


(John Brock) #12

I have not heard of any progress on a Mac Rhino Vray plug-in.


#13

I started to check out other render engines. I will have to check the Rhino 4 mac plug in compability.
Cheers for your time.

Sincerely,
Raoul


#14

Thanks for clarifying. Now that you have a Rhino Mac version, you must have Macs around for support. Do you ever run Windows Rhino on them under Parallels and VMware for actual hands-on experience in how well (or poorly) it works, or do you just rely on field reports and other sources?

ps: I’m not going to suggest that you should start offering support for virtualization since it certainly involves a lot of moving parts.


(John Brock) #15

Yes, we all have Macs now in addition to Windows computers. We gave up on Parallels long ago when it became obvious it was a mess. Some of us use VMWare for testing and development use. We ignore the virtualization issues for the convenience of maintaining fewer computers. The problems related to virtualization are still too great for us to officially support it for customers.


(Steve Baer) #16

I’ve done a lot of V6 for Windows development on a VMWare Mac with the hope of supporting it as well as possible. VMWare supports up to OpenGL 3.3 which is a big improvement over Parallels which only supports up to OpenGL 2.1. It still pales in comparison to native Windows, but we are trying to do our best at support.


#17

Same problem, the SetDpiAwareness worked for me.
thanks


#18

I just had the same problem and the SetDpiAwareness seem to have worked for me as well. The text in the command line seems smaller now though, anywhere I can change that?


(Wim Dekeyser) #19

Rhino Options > Appearance > Command prompt > Text size
HTH


#20

Thanks!