Object snaps OSX


#1

We have been having trouble with object snaps in rhino OSX (macbook
pro OSX 10.9.3).  as you are trying to select a snap the pop up window
jumps around from one option to another making it very hard to select
the right one. what often seems to happen is that it does not quite snap
to any option though you think it has. later you discover when you zoom
in that lines or points don’t actually meet after all. i have tried
various setting options but the snap is offered in PIXELS which seems
strange: if the model is large, this can mean an unacceptably wide
tolerance. people using my OSX drawn models in windows (which does not
have this problem) complain about my imprecise drawings.
Is this me - or the limitation of the settings option?
David


#2

What snaps do you keep turned on? I have most success (and accuracy when sharing with Windows) with End, Intersection, and Point being on always. The rest I toggle on/off as needed.

Recommend turning “Near” off unless specifically needed for a snap. This snap is usually responsible for inaccuracies with end points.

Also, depending on the complexity of your geometry, Planar is also to be used carefully since snaps will appear accurate, but will be projected to a CPlane which may be visually close by, thus creating gaps if you zoom in very close.

~Dave


#3

This (pixel value) has nothing to do with the accuracy of the snap, it is only the radius within which the snap will activate. If it’s on when you click, it’s dead accurate… so if you are having problems with people complaining about “imprecise drawings”, there is some other problem.

What are your file tolerances? You can’t expect accuracy any better than your absolute tolerance is set.
And, as Dave said - turn Near osnap off! It’s a recipe for inaccurate modeling…

–Mitch


#4

Thanks very much for your help Dave. I think you are right about having too many snaps on. i was relying on being able to select the one i want, but i think that the mere act of pressing the mouse slightly shifts the selection to a different snap, but happens too fast to see. You are also right about planar which i have now switched off!


#5

Thanks Mitch. Now I understand the pixel setting!
My absolute tolerance is 0.001mm, relative 1.0%, which are the same as our Windows settings.
Please see my reply to Dave also in this thread about the cursor jumping fractionally when I press the mouse to select.
David


#6

Just note that Planar does not project Osnaps, Project does. Planar will keep non-snapped points on the same plane as a previous point instead of projecting then to the CPlane.

–Mitch


#7

Mitch is right. I misspoke: “Project” is what I should have said instead of “Planar”. Sorry for the error!!!