Osnap doesn't seem to work

I have object snaps on, with end, point, midpoint, centre, intersection and vertex checked. SmartTrack is checked, Project is unchecked.
I’m making simple 2 dimensional shapes in Top view which will be output as dwg for laser profiles.
I can get the snapping cursor to appear, but no hints to show end, midpoint, or whatever. Snapping of, say, the end of one curve to another is hit or miss, certainly not “snappy”.
Can anyone say why?

hmm center can often cause a dominant snapping behaviour making it almost impossible for other snaps to work properly, also grid snapping can be very dominant… try if deactivating both helps.

Grid snap is off. Centre off or on makes no difference

than i can only think of when modeling extreme small out of tolerance, the snaps do not work anymore. happens when you import a model wrong and its a multitude smaller. have you got a file to look at?

The object I am editing is about 950x185mm; I don’t know what you mean by “extreme out of tolerance”.
Absolute tolerance in units is 0.001mm, relative tolerance 10%

What’s your snapping distance set at? And when you say snapping one curve to another, you mean starting to draw a new curve, right?

If this was Windows, I would say it was a graphics card problem, but on Mac, don’t know. On Mac, is there a section Preferences>Modeling Aids>cursor tooltips? If so, are the “Enable” and “Osnap” boxes checked?

How are you doing this? By using the command Move, or snap-dragging?

–Mitch

Can’t see any way to set a snapping distance for object snaps. Drawing new curve or dragging existing one.

In Rhino for Windows the radius for OSnaps can be set in pixels. Also cursor “tool tips” including OSnap name can be toggled on/off. No idea if Rhino for Mac has similar.

Graphics card is Ati Radeon HD5870 1024Mb, so not great but surely adequate? There is no Modelling Aids section in preferences. Osnap is definitely on “persistently”

Just checked on a student’s Mac Rhino here, yes, there is a Modeling Aids section in Preferences and, yes there are the settings I mentioned above.

–Mitch

My apologies, I was looking under settings, I do have that section under preferences. Cursor tooltips are enabled.

Behaviour still same though

when your objects are far too small that the snaps dont grab anymore. as i said to post your file or a part of it would be probably the best for anybody to help you further.