OSnap hasn't been working for me since I downloaded Rhino

Hey guys so I just recently bought and downloaded Rhino 6. I’ve been trying to use it but my Osnaps are not working at all. To show whats happening ive linked a video. (sorry the video is quite bad) I have all the osnap setting checked and still wont work. I’ve also looked up this problem and found other post on this forum about it with people saying to change the pixel radius which I’ve tried. I can see anything that will work, this is really frustrating as I was really looking forward to learning rhino but this is almost making it unusable in my opinion…

Thanks guys

Hello - it is hard to see what is going on - can you make a line and then start a new line with End osnap on and snap to the end of the existing line? Does that much work?

-Pascal

Hi Pascal, thanks for the reply. Just tried again and its still not working. Cant get a new line to snap to the end of any lines. I’ve tried uninstalling and installing again. Have also tried repairing rhino and nothing has worked.

Hello - can you please run SystemInfo in Rhino and post (copy/paste) the results?

-Pascal

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Educational, build 2019-07-09
License details: Cloud Zoo. In use by: Kolton McConkey ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-8R8JAFH

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 8-13-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 2GB, Driver date: 8-21-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 399.07

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-21-2018
Driver Version: 24.21.13.9907
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - that looks fine, I’d say - let’s just make sure we’re on the same page - is this what you are doing?

-Pascal

Yeah that’s what I’m doing. Here’s a video of me doing the same thing.https://global.discourse-cdn.com/mcneel/uploads/default/original/3X/1/3/139df9e2ed3097191092eb7b185601350fe2e11c.mp4

I see - this is new to me, I think… is your input via a standard mouse?

Can you make a grab of this page in Options? I’'m wondering about the marked items especially …

-Pascal

I got it figured out, it was the “Only snap to selected objects” that was causing the problem. I don’t remember checking any boxes in there.

Thanks for the help Pascal! Really appreciate it

I had the problem with Osnap not snapping in Rhino 7 until it occurred to me that my computer was not calculating to within 0.001 mm. My fix was to change: -
Tools | Options | Units | Model | Units and Tolerance | Absolute tolerance from 0.001 mm to 0.1 mm. So the critical Absolute tolerance on my computer is between 0.1 and 0.001.
I hope this may save someone some time.

Re-reading the conversation, I previously missed Pascal’s solution. It certainly works for me now. Since the points were originally not becoming coincident it seemed to me to be a mathematical feature rather than a graphical one . . .

Osnaps are independent of the absolute tolerance setting. Osnaps do depend on the Snap Radius which has units of pixels and is set in Options > Rhino Options > Modeling Aids.

Absolute tolerance should be set depending on the modeling requirements.
https://wiki.mcneel.com/rhino/faqtolerances

Hello,

The same happened to me in Rhino 7. I did not check the “Only snap to selected objects” either but found it checked. Also the option: “Center Snap to approximate arcs, circles and ellipses” is un-checked. Is it adventurous to have this this checked ?

Thank you,

Andy

Thank you David. I have a much better understanding now.

I checked this, and mine has these not ticked and matches yours. But for some reason, my osnap suddenly stopped working. What do I do