No font-weight support?

font
textobject
weights

#1

When I want to create an object with _TextObject I don’t get an option to choose the font weight.
It seems like only the default weight “regular” is possible.
But I’d like to choose from other weights like thin, light, medium or bold.
Probably I’m missing something?


#2

any feedback on this matter?


(John Brock) #3

TextObject uses font definitions to create curves, surfaces, or solids (closed polysurfaces). In the context of geometry, those “weights” aren’t meaningful.
It’s strange to me they are on the command control.
That seems like a bug.
They should be suppressed or grayed out.
I’ll see about getting a bug on the pile.


(John Brock) #4

https://mcneel.myjetbrains.com/youtrack/issue/RH-40147


#5

OK, that I didn’t know.
But now it makes sense to me,
thanks for explaining.


#6

But WAIT!
My understanding is that the different weights like thin, light, medium or bold (aka 300, 400, 600, 700) are not just the regular font but with a higher line-weight or scaled or skewed like for cursive.
they are different and independent versions of that same font (but in one file). together they are a “font-family” - at least that’s how I think it is, but I may be wrong of course.


(John Brock) #7

It’s only the Underscore that should not be in the control.
Bold, normal, and italic work.


#8

OK,
now please take a look at Roboto over at Google Fonts.
This very popular font has not only two (or four with italic) versions/weights but six (12 with italic).
Most text editors make it possible to choose between each.
I hope this would be possible in rhino too?

Maybe rhino just assumes that the desired font only has two weight plus italic and so they can be chosen with bold- and italic-buttons. I guess something like a dropdown for choosing between the different weight would be desirable.


(John Brock) #9

I am aware of a few fonts that do not support these features. If I remember correctly, they are CityBlueprint and something similar. I think there is something “non-standard” about their definitions.
Sounds like this is another one.

After a chat with the developer, I don’t think this is something we can work-around on our end.


#10

I’d say that every proper font is build like that and has more than just bold and italic - just look at all the fonts at google-fonts and elsewhere. There is nothing “non-standard” about fonts beieng designed as a family. That’s actually how it’s supposed to be.
So I think it wouldn’t be a matter of you finding a “work-around” but more like making a proper implementation.

Of course there are other things far more urgent, but I guess it would surely be welcomed by many users.


(John Brock) #11

As I tried to explain, our developers that hooked that up, told me about this limitation with a few fonts they were aware of, but did not have a work-around for it.


(Melter Oto) #13

I think there is some misunderstanding here…the font weights are actually a different font, you cannot scale the line thickness of a letter automatically to get the thin out of regullar, they are different shape…and proper fonts have this definitions built into them…it seems, that r5 font options are more advanced that r6…I (and loads of others) would really appreciate if this funtionality was added back…thank you!

example: font Oswald…in r5 i can choose all the different weights, in r6 there is just regular and no preview


#14

Yes, I tried to explain that to the rhino devs a few times now. I had continued to ask for it over here:

first they said it wasn’t possible to simply do that (which to me seems like they just don’t understand how fonts work), then they realized that rhino5 does it. So i guess the support for font styles is of course implemented, they probably just somehow missed giving us access to it, simple gui thing i assume.
@melter.oto please make your voice heard in the other thread as well, thanks.

EDIT:
the discussion in the bug report seems to indicated that they’ll have it fixed soon:
https://mcneel.myjetbrains.com/youtrack/issue/RH-43456