Wish: Font Styles

I use some GoogleWebFonts and I noticed, that Rhino _Text isn’t able to access the many different styles.
Try the very popular Roboto font for example (customize and check all the styles before downloading the zip):

or Roboto Mono which goes well with technical drawings:

There is only the “B” and “I” button for making it bold or italic but that feels like using a text editor from the 90s. Rhino is supposed to be a design tool, right? Hope we will be able to access the different font styles soon.

Or maybe it’s possible and I just have missed something here?

Do those fonts actually reside on your computer, or are they somewhere in the cloud? Currently Rhino can only access Truetype/Opentype fonts installed locally on your machine (as far as I know).


Yes, they are properly installed on my windows 10 system. When you download them as zip they come as TrueType font format.
Other design programs like adobe illustrator or affinity designer have a dropdown for the font and right beside it a second dropdown with wich you can access the different styles. No old fashioned “B” and “I” buttons there.

I know this will probably not have a high priority but I still think it’s a must have.

Oh dear. That is a slippery slope. “A design tool” is not the same as “the only design tool cause it does everything”, as much as we may want to conquer the universe. By all means keep asking (I have no idea what this particular request entails) … but on the other hand, don’t wait under water, as they say…




I just ran into the same thing and noticed, that it actually worked in Rhino5 on my Computer and now seems to be broken, see the following examples:



1 Like

Hey, you’re totally damn right! I really hadn’t used rhino5 for a long time now, but yes, just tried it - all the different styles of a font are available in rhino5, just as everyone would expect.

So that means, that the absence of this in rhino6 is less a missing standard feature but more a bug, since it has already been there in rhino5.

I’m surprised that @pascal didn’t realize this. Hope it’s just a little tweak to bring it back?

Yes, not all fonts visible, in text, textObjet
but visible in Appearance Command Prompt

1 Like

Got that, thanks,



1 Like

Just want to say, that I would appreciate this to be solved as well, thank you for looking into it :slight_smile:

1 Like

It is fixed in SR5. Now that SR4 is out, you should get a release candidate of SR5 at some point in the near future if you’ve signed up for those.


great news! so glad you didn’t forget about this.

It’s all in the system - no way to forget about it.
At any rate, if you check that YT issue, you will notice that it isn’t marked as fixed yet. You can pick font and style but there are still some related issues to work out.

Hi, is there any progress? There is already SR8 and it seems it is still not fixed :frowning: Or am I wrong?

1 Like

I’m not sure. The YT item seems undecided.
From what I can see on my system, there are several style of a particular font available.
Are you missing font styles? If so, we’ll try to get the bug item on the road again…