No control over Tessellation?


#1

I’ve been using Rhino on Mac since last spring. When I first started using it, I was allowed to control the Tessellation of an cube regardless of if I had moved points on it or not (no isocurves).

Now, since the Fall, it seems like, if you don’t turn control points on (and move them a bit) to get the isocurves, then I have no control over that cube for Tessellation.

Will it ever go back to the way it was?


(Brian James) #2

Hi Brian,

This is due to the default box being an extrusion object versus a polysrf. You can use the command ConvertExtrusion to change the extrusion into a polysrf and them it will mesh as you expect. There is also a command called UseExtrusions which lets you decide what Rhino will make when what it creates could be considered an extrusion. These light weight objects are new to Rhino 5 and reduce file size… one way in which they do this is with a custom light weight render mesh which is what I believe is preventing the dense mesh conversion here.


#3

Most likely your Rhino is set up to create extrusion objects for thins like boxes, cylinders etc. (as well as extruded planar curves). One clue is that extrusion objects do not show isocurves as you remarked. If you check properties for the object, it will also mention the fact. Extrusion objects are special “lightweight” Rhino objects and their meshing parameters do not respond to the normal mesh commands.

In order to get your extrusion objects to respond as you would like to meshing, you need to convert them back into polysurfaces. You noticed that moving a control point does that, however this is not necessary. Simply call the command ConvertExtrusion on your selected extrusion objects, that will turn them into surfaces/polysurfaces.

If you would like to turn off automatic the extrusion creation behavior altogether, Call the command UseExtrusions and set it to No. That way when you make a box, it will be a polysurface from the start.

HTH,

–Mitch


#4

Awesome! Thanks so much. That helps a lot.