Isocurves show by default Rhino5


#1

Hello,
I just switched from Rhino4 to Rhino5.
I like having isocurves on by default because it makes selecting objects easier in plan/section views. However, I can’t find the options to have them on by default. I know there’s the option to turn it on per object(s) in the properties tab AFTER I create the object, but that’s an extra step that slows me down.
How do I have isocurves be on/shown right when I create an object/extrusion/box?

Thanks!


(Wim Dekeyser) #2

Extrusions (like a box) won’t have isocurves. You’ll have to convert these to polysrfs - and these should then display isocurves in the default display modes.


#3

Are boxes not extrusions in Rhino4? Does clicking the “Show surface isocurves” in properties turn an extrusion into a polysurface? I don’t understand.
Is there a way to turn on isocurves by default for extrusions then? It’s still an extra step, since I work primarily with extrusions, and I would have to extrude->select object->open properties->click show isocurves. I’d like to have the isocurves show all the time, or is that no longer an options in Rhino5??


(Mary Ann Fugier) #4

Hi.
Rhino 4 does not have extrusion objects. Extrusions were added to Rhino 5 as way to make the model smaller and more efficient. An extrusion is a planar curve and a direction curve. Only certain objects quality to be extrusions. Also ConvertExtrusion will convert an extrusion to a standard brep.

Their isocurve density is set to -1 for performance reasons.
In addition, it is a good way to differentiate them from standard polysurfaces or breps.

Since the isocurve density is set to the object, there is no document parameter that control this.
You need to change the Properties of the object. You can do that efficiently with a macro.
This macro selects all the extrusions objects and set the isocurve density to 2.

Copy this macro on to toolbar button and try it out :
! SelExtrusion -Properties Object IsocurveDensity 2 Enter Enter

Sincerely,
Mary Fugier


#5

In File>Properties, or by selecting the options icon in the standard rhino toolbar, you can find the setting to select default isocurve density under General. Regardless of the isocurves generated by whatever geometry you are using (which wasn’t the original question) this will set the default density. If a geometry doesn’t have isocurves by default, then they won’t be shown.