No control points on extrude curve straight?


#1

Switching to Rhino 5 from Rhino 4.
If I create a simple curve and extrude it straight into a surface, when I turn control points on, only three points show up. If I rebuild the surface and increase the points, the same three control points remain. ( if I move them it displaces the surface)
Do I have a setting wrong?
Only happens with extruding curve straight.


#2

Hi,

Rhino 5 creates extrusions for simple shapes. These is very “light” geometry considering RAM usage etc. This is why you can’t modify them directly (they don’t keep a simple shape then). You can then only modify the input of the extrusion. You can switch that type of geometry off (_UseExtrusions), and also convert it (_ConvertExtrusion).

Cheers,
Michael


#3

Michael,

Thanks a lot!


#4

hi,
I’m new to rhino and I had the same exact problem with the extruded curves control points that j3001 asked.
I know the answer is right here in front of me but I just don’t get it. I don’t know what useExtrusions command or … is .
could you please explain it a little more??
thank you so much for the help


(Wim Dekeyser) #5

I assume you read this:

useExtrusions command
Extrusion objects are defined by a profile curve and a straight line. They use less memory and mesh faster than polysurface objects. They are a good option when making models containing lots of simple shapes.

ConvertExtrusion command
Converts extrusion objects to surfaces and polysurfaces.

Could you pinpoint what it is in this that needs clarification?


#6

Thank you very much. I got it :smile:


#7

I had the same problem and understand now how to get the control points to show properly for an extruded surface from a curve. However I have a different questions that somewhat relates to this.

I have been using Rhino 5 for the Mac (WIP) and I have been using the setting in Preferences/Themes/Commands, where I have chosen “Use Commands options dialog”. With this setting in place, how do I execute the “ConvertExtrusion” command?

The only way I have been able to figure out how to get to the command line again, is by changing the setting to “Command options in sidebar”, but this only takes effect after opening a new window, i.e. a new file.