New to rhino-file too slow

Im an interior designer and i just use rhino to build 3d models of my projects to show clients
i dont render, i use rhino in its most basic form - create 3d models, assign materials, add some lighting etc. and to take shots i do '‘capture to file’'
nothing more , its all i need from the program
I’m doing a 3d model of a tattoo shop- Ill attach a screen shot photo of my screen
Theres a lot of wood planks (just square command with assigned material)
I built some lights, and theres a lot of tile, again just shapes extruded with either a material or color assigned to it.
Also when I say material, its simply a jpeg from google images.

So my file is SO SLOW every time i move my 3D it takes forever to do ANYTHING even to delete an object
please help because im about to throw my computer out of my window

It may be useful to list your computer specs.

Also sounds like you have a LOT of elements in there and if they all have large texture maps it may bring Rhino’s display capability to it’s knees… I didn’t see the screenshot attached. --Mitch

@meldsgn have you tried turning on the bounding box display option? On the Display panel, check the BBox Display option under Object Settings. You can display the Display panel off the Panels menu at the top of the screen.

Does that help?

Also, I would highly encourage you to call McNeel and discuss your issue directly.

Is the model slow in wireframe mode?

What type of computer do you have and video card?

If it is only slow in shaded or rendered, then we can probably speed up the model with mesh settings:

So i run windows on a macbook pro retina display 2.6 ghz processor intel core i7
8gb memory 1600 mhz ddr3
Intel hd graphics 4000 512 MB

It’s slow in both wireframe and rendered, a little faster in wireframe but still off.
Is it possible I have a virus in the file ? or on my computer ? because I have done similar files and they
have just as many objects and I’ve never had the same problem

I will try the mesh settings Scottd, thank you

Also, I should probably tell you guys that the windows im running isnt exactly legal, cracked it online…
Not sure if that makes a difference in the performance of my rhino or not

The Mesh adjustments haven’t made a difference

Hi cosmas, where are the settings? the display panel?

It’s near the bottom of the “Display” panel – one of many tabs/ panels that can be “displayed” (for lack of a better word) by going up to the Panels menu on the top of the screen, scroll down to “Display” and put a check mark next to it.

When you check the bounding box option, the program substitutes bounding boxes when you move the camera. This helps you move your camera over your model more freely.

Does that help?


I just noticed that you’re working on bootcamp. Is it parallels, by any chance? Parallels can be really slow.

No it’s not parallels it’s boot camp

Convert the nurbs to mesh and join the meshes. That should speed it up for you, as Rhino is good few objects, and at handling meshes.
(Do it on a duplicated file, so you don’t mess up your model) and know that Rhino can’t make 2D of meshes.

If it is slow in wireframe, then it is not a mesh problem. There are a number of possibles:

  1. Are objects duplicated? Sometimes models will become duplicated on top of each other. Running Seldup command will show if this is a problem.
  2. Are there hatches in the file. Hatches can display slow. Are the hatches single lines, or do they select as a pattern?
  3. Does the model have many nested Blocks? This can cause performance issues.
  4. The Intel 4000 graphics is not the best for performance, but what you are describing is quite slow.

You can send us the file using this form:

I will take a look to see what is happening.

Also, if there are many lines/curves that use different line types (dashed, center etc) this can slow things down a lot - especially, as can happen , if these are scaled very small. If you think this is a possibility, try the LineTypeDisplay command and turn line type display off to see if there is any difference.


I have an nvidia geforce gt 650m
intel® core™ i7-3720qm cpu @ s60 ghz 8gb ram
2880x1800 res, 60hz
running on my windows bootcamp.
Rhino reads that card
no hatches, no nested blocks, dont even know what that is
I will try the seldup command!

I will send the file now!

Yep, there are many many objects in the file- many of them repeated objects - tiles, 20 thousand and more. If you select all the repeated tiles and Mesh them all, using the '‘Detailed controls’ and set the ‘minimum initial grid quads’ to 1 and check Jagged seams, then delete (you may want to do this in a copy of the file) things should improve a great deal. In addition, you can select all the meshed tiles that have the same material and Join these into a single mesh, it will improve things a bit more as well. I’ll send a ‘fixed’ version back to you via your note to tech.


There are also tricks to rendering, where the floor is modeled as a single surface. Then the tiles and borders are bit mapped in the correct place to allow the render engine renders what looks like tiles.