Rhino 5 - very slow performance


(Toshe Andonov) #1

Hi everyone,
A new user here.

Few weeks ago I’ve decided to move my whole workflow over to Rhino, since I love how it covers everything I need in one single software, AutoCAD + Revit + 3ds Max+Vray - Still waiting on Corona :slight_smile: .
Surprisingly the learning curve is very fast. Maybe since I’ve been doing this for awhile, but the community is of huge help, sharing everything all over the place. Thank you!

I’ve made this switch with a new project for a nursery school.
Everything was going fine, until the project started developing and the 3dm file reaced ~100MB.
Now at ~230MB the performance is very sluggish. Rotating and panning around takes a huge effort and time and opening menus and starting new commands, also. Switching between viewports takes about 30+sec.

I thought that the polycount was huge, since I’ve imported few OBJ files (terrain, trees and furniture), and Rhino was very efficient at optimizing, but the polycount barely reaches 100k.
Tried importing into 3ds Max, but there everything runs just fine.

I’m running the 64bit version on Windows 10, i7 2600k, 12GB RAM, GTX 560. I know this is not the most powerful machine, but it manages much larger projects than this one.
Also, I’m using a 3dconnextion mouse if it makes a difference, but it seems to me it doesn’t.

Inside, I have VisualARQ installed and all the walls, stairs, railings, windows and doors and made with it.
Plan views are in Hidden and Perspective is in Shaded, but I’ve tried switching between all the others and no significant result, if anything, some run even slower.

I’ve attached screenshots from the Display Settings.

Is there something I cannot understand on how Rhino works?

-View Options

-OpenGL

  • Shaded/Perspective

  • Hidden/Plan


(Pascal Golay) #2

Hi Toshe - by slow performance I take it you mean only the display as you pan and zoom and rotate views, correct?
If your model is organized on layers, you might try turning off layers one at a time to try to isolate the objects that cause the slowdown.

Also, as a test, disable some plug-ins in Options > Plug-ins then restart Rhino - See if things run better without VisualArq for example, or others if you have them.

Is performance OK in Wireframe viewports?

-Pascal


(Toshe Andonov) #3

Thank you for the response @pascal.
Yes, Navigating and especially switching between views is very slow.

I wrote this, only after I’ve stripped down the model down to the core of the VisualARQ building which is a 21MB. I’ve deleted all the imported stuff and all the linework.Only the layers created with the plugin are now present.

And yes, Wireframe seems to perform the best in Perspective view. It’s very smooth. In Plan view it’s still sluggish.
The thing is, I prefer working in Hidden for Plan or Shaded display mode for Perspective.

Disabling the VisualARQ plugin makes no difference.

But disabling the grid I’ve set seems to fix the problem. I don’t get it.

Should I reinstall Rhino? I’m coming out of a freshly formated PC with everything installed on a SSD drive.


#4

I have found too the grid display has a large impact on low-end graphic adapters.
F7 to switch of the grid helps a lot.

-C-H-A-R-L-E-S-


(Pascal Golay) #5

Good catch @Charles@ANDhitecture… so, is the grid very dense? In any case, I’ll check with the developer to see if we can’t tune this up in V6,

-Pascal


(Toshe Andonov) #7

Doing architecture in mm, so yes, the grid is very dense. But switching it off seems to fix the huge lag.

Now it only lags for short bits but that’s fine. I am really surprised how much I love the ease of work in Rhino, so I will “look away” on few glitches here and there. :slight_smile:

I was going to get a new GPU anyway, so we’ll see how it goes then.
Also, I’m about to start a new much larger project, that will surely be a test for both this software and the hardware.
Let’s see how that goes and then I might get it for the whole studio.