Near snap on surface edge?

I have an issue with Osnap where Rhino dominantly snaps to the Center of a surface but I’d prefer a Near snap somewhere along the surface edge.

I can choose in between Near snap and Center snap on closed curves but can’t get a Near snap on a surface edge.

Turning Center snap off is not a solution since I need it.

Hi Martin - it depends a bit on where the mouse is in relation to the edge and a possible center, but it can get tricky, yes. You can force a One Shot snap by either typing the snap name (here “near”) or by hovering the mouse over the Osnap panel while holding Shift:

image
-wim

1 Like

Thanks for the hint on One Shot, I’ve never used it before.

Regarding the regular Near snap being tricky, explain me how I can get a Near snap on an untrimmed rectangular surface please? I manage to Near snap on surface edges of certain trimmed surfaces but on a simple rectangle it always snaps straight to Center.

You’re going to either need to turn off Center or use a one-shot Near of oyu want to get ‘somewhere’ on the surface edge. For me, Center has always been “too strong”, it overrides a lot of other stuff, so personally I normally leave it off and only turn it on when I really need centers (one shot or persistent just for the operation if I need a lot).

1 Like

One Shot Near is a workaround in my case. But it takes like 40 cm of mouse movement.

Center snap is so strong it disables Near snap? Weird.

Why is there a Near snap on some surfaces but not on others?

In the file attached there’s a green trimmed surface where Near snap works if the mouse is outside the surface. Once the mouse is inside, you get Center snap.

The red surface is an untrimmed square. There is no Near snap option on this one. No matter where the mouse is. That doesn’t make any sense.

20_02_04_osnap_issue.3dm (70.4 KB)

PS: Unfortunately I’m unable to record a screen video where the context (Near/Cen) is visible.

Near works here on both of those surfaces here to snap to the edges… Note that Near only snaps to curve type objects (curves and surface edges) - it does not snap to surfaces or meshes. For snapping ‘somewhere’ on a surface other than the edges, you need the OnSurface object snap (persistent or one shot).

You could also set a short cut to toggle the osnap if your having issues.

God to properties>Keyboard. Select a short cut you like and enter _Osnap Center Enter. That’s all you need to do.

not looking for workarounds

getting closer…

why can you Near snap on the red, rectangular surface and I can’t?

Hi Martin - are you looking for the edges of the red surface with Near? That does work here…

-Pascal

1 Like

Yes I’m wondering why it works for you and not for me? It’s exactly the same situation in Rhino 5. Whenever I’m outside the circular shape I can Near snap. On the square I only get Center snaps…

Hi Pascal - that doesn’t work for me either. Note that the Center Osnap needs to be on when testing this.
-wim

Got it now - sorry. Yes, that seems wrong…

-Pascal

I’ll file that…
-w

Filed as RH-56862

1 Like

Yes, center is definitely too strong - and has been for a looong time… I’ve been complaining about this and other osnap “strengths” many times, but McNeel doesn’t seem to agree :sunglasses:

Philip

Hi Philip - over time there have been lots (and lots) of tweaks to the strength of the Center snap.
In the case of the rectangle, there’s something wrong, obviously. But if you run into other cases that still seem wrong, just send them along!
-wim

1 Like

I see… It’s obviously a difficult problem then. There are other problems with osnaps as well. “Perpendicular” is another one, for instance.

This would be my list (once again :wink:) for the strengths of overlapping osnaps - from the strongest to the weakest: point, end, mid, quad, vertex, int, tan, center, perp.

Philip

Is there any chance the ability to change the snap weights can be given to us for R7?

I’ve suggested that too - but I think it would be better if we could manage without adding more settings. Rhino already has too many ‘buttons’…

Philip

Hi - I agree with @Philip here - I really don’t think that adding a bunch of settings is the way to go.

Mikko already fixed the issue with snapping to the edges of a plane and I’ll test that when a new internal version is ready.

When you have an example of something that doesn’t work, please post that here so that we can take a look. So, Philip, please post a simple example where Perp isn’t working for you.
-wim