NamedView causing delay in Rhino 6

I’m currently running Rhino 6 on Macbook pro 2019, and found when switching among namedView, a huge amount of delay would appear as the cursor would swing for 10s+. Same problem happens when switching among 4 views.

Any suggestions to optimize the speed?

The specs are,
Processor Name: Intel Core i7
Processor Speed: 1.7 GHz
Memory: 16 GB 2133 MHz LPDDR3
Graphics: Intel Iris Plus Graphics 645 1536 MB


Hi @chen2,

Just curious, is the Named Views panel displaying items with a thumbnail image? If so, right-click in the control click View Mode > List. Does this help?

– Dale

Yes, problem solved.

Thanks Dale!

Hi @chen2,

Cool. Hey, how many named views did your model have? I’d like to try to repeat the slowness here.

Is it possible to get a copy of your file? (or one that repeat the slowness?)


– Dale

Hi Dale,
I have 20 views, sadly I can’t share the model since it’s a work file. But the size is 135MB and I’ve run it in Rhino 5 with the same laptop, 5 worked smoothly.


Hi @chen2,

Thanks for the details.

– Dale

Yeah. We got the same problem, and the workaround helps for now.

Would be even better to solve the underlying problem, though.
Does anybody have it on his/her plate? @dan ?

I’d say this is an error.

Hello @dan , could you take a look at this?

Figuring out how to speed up these thumbnail views is, and has been on the list for some time. It’s not a simple thing to fix.

1 Like

Sorry, I’m not able to reproduce this issue. I think having a file that demonstrates this issue would be really helpful. Lacking that, I was reduced to making something up…that didn’t work.

Hi, now that it’s been a while, I’m going to share this archive file with you. If you could reproduce the issue please let me know. There are delays but not as terrible as the initial moment when I encountered the problem.

Hi Chen-

I appreciate your willingness to share a model. Unfortunately, I’m getting a 404 error trying to access that model via Dropbox. Maybe the permissions are wrong. If that doesn’t work, you could try:

and please add and paste the link to this discourse topic into the Comments section. Thank you in advance!

Try this one:

I’ve also uploaded a zip file to your email address. Please let me know if neither of those works.

I’ve sent you a file with which we had that error.

You’ll just have to switch back from “list mode” to “thumbnail mode” in the named previews panel (I don’t remember the exact naming here …).

Thank you for the models. This is evident now. Logged in:

RH-56728 NamedView: Thumbnail mode: Switching between views is slow

Much appreciated.

RH-56728 is fixed in the latest WIP