Strange delay problem

Hi everyone,

I have a Rhino6 Educational License. It always worked fine, but recently it exhibits a strange behaviour. When I open Rhino I see all the views black. Then, when I click onto one of the view bars (e.g. on “Perspective”) all views become visibile (like they should by default upon opening Rhino) but I don’t switch to Perspective view. Then, if I click to another view bar (e.g. “Right”), I switch to perpective view, and so on: it seems that the command is received with a delay of exactly one command. Moreover I can’t even move or rotate any view (or rather, I can, but I see the effects only after clicking to a view tab). Same thing with most common commands to make lines and surfaces.

So the program still works, but it’s not functional to use it like this. Any idea?

Hello - this sounds a bit like a plug-in may be involved.

Please run the SystemInfo command in Rhino and copy/paste the results here.

(Also, if you have not, close Rhino, reboot, try Rhino again.)


1 Like

Thanks for the quick reply. I already tried to restart Rhino and also to unistall and install again.

Here is it:

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Educational, build 2021-02-03
License details: Cloud Zoo. In use by: SGSS Licenze ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: LAPTOP-JP68LVTV

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 6-2-2017 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce 940MX (NVidia) Memory: 4GB, Driver date: 9-23-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.41
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-23-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - the only thing that jumps out at me is the driver on your Intel is old - please update that driver, and the NVidia as well to the latest available from the Intel and NVidia websites, and see if that improves matters.


1 Like

Thanks, Pascal. Unfortunately I updated both drivers but still no results.

Any other idea?

Hello - can you run SystemInfo again just so we can make sure Rhino sees the updated drivers, and can you please set a startup template file for Rhino that is not your usual one? Do this in Options > Files page. Does that change anything?

And, can you tell me if you have any scripts loading at startup:

or any startup commands:


1 Like

I am sorry Pascal but I made a complete Windows update and it seems suddenly working now. It was evidently an issue with the drivers.
Thanks a lot for your help.