Rhino 7 - Named View Window Bugging

Rhino 7.1.20299.23101

Every time I open the window for Named Views, Rhino drastically slows down and sometimes blocks. Does anyone have the same problem?

Hello - are there many named views? Are they showing thumbnails? If so, right click and change the ‘view mode’ to ‘List’.

-Pascal

@pascal Yes, there are around 10 views in the file, but the same file with the same number of views works just fine in Rhino 6. Do you know what has changed in Rhino 7, so the Named View window becomes so hard to handle?

I’m having this issue.

When I open Named views on thumbnail, the named view panel is ‘black’ when I open it, takes a few seconds (5-10) before it shows thumbnails. Renaming or clicking the Named Views is very slow. Task manager shows a massive load in power usage when I try to use the Named Views, but CPU and GPU don’t change much.
Changing to list mode does help some. However, I don’t seem to be able to rename a named view while in list view.

A couple of notes. I’ve recently upgraded to Version 7 SR5
(7.5.21100.3001, 2021-04-10), and am running V-Ray for Rhinoceros 6 4.20.03. This file has a lot of embeded blocks with render materials etc. My ‘named views’ were saved in ‘arctic mode’ as early render previews. I’ve had this issue in other models that aren’t so large, but the issue does seem worse in this model.

I found an older post for Rhino 6 which said this issue had been resolved. Is this a new iteration of the same issue?
Rhino 6 fix for this issue.

Unfortunately I can’t share this file at the moment. I could try and recreate it in another file if required.

Hi -

Yes, please. I’ve tested this some here and can’t reproduce a slow-down with thumbnails shown.
-wim

Hmm, I’ve just opened up the file again and had a play around with it.

On Wednesday when I was working with it last, it was super slow to respond. I saved all the views I needed (there are about 12) and then deleted all the named views (about 12 as well) with the ‘artic’ view setting on. I did notice a small change then. But I’ve also since done a purge and save, close, shutdown PC etc and when I reopened the file just now it was much better.

I did a bit of a test and when I saved another ‘artic’ view, it starts to slow down again. When I click the ‘artic’ named view it’ll switch to it pretty quickly, but when click on a regular ‘shaded’ view it takes about 5 seconds before I can do anything like rotatet the view. This is similar to the behavior I was getting on wednesday after deleting the ‘artic’ named views.

The file I’m working with is 350mb, which is a combination of embeded blocks, possibly textures and native Rhino Geometry.
I’ll see if I can get it doing the same behaviour with one of my test scenes.

Chris.

Im having the exact same issue in Rhino 7, I cant even delete views without the computer taking 5-10 minutes to “think” through it. This is impossible with render workflow. Anyone at mcneel, how can this be fixed in rhino 7?