Naked edges on this specific model

I’m desperate here folks. I have 4 naked edges on this model but cannot for the life of me figure out what’s wrong. Every time I analyze it looks to be perfectly aligned and joined. I’ve recreated it entirely twice and just haven’t been able to pinpoint the problem and, therefore, haven’t been able to fix it. Hoping someone here could help figure it out! It’s very simple model so it’s been pretty frustrating.


Insert.3dm (216.4 KB)

Have you tried Remove Naked Micro Edges, _RemoveAllNakedMicroEdges .

To fix this, use Extractsrf to remove the topmost planar surface and delete it. Then run Cap command then run Trim to cut out the middle and then run Join to get a closed polysurface.
Insertx.3dm (131.6 KB)

I did! It doesn’t recognize any edges to remove. Thank you though!

I followed your steps - worked perfectly. Thank you so much! How did you know that would resolve it? I kept thinking it was the inside wall that was the problem.

If you work in parallel viewport you can zoom way in and see the defective edge.
Then you can run the ExtractSrf command and click on the bad edge ( selects the surface with that edge) and then run Untrim command and watch that bad edge disappear. After zooming back out I saw that the badly trimmed surface was a plane and cap is a pretty reliable way to replace a planar surface if the other edges are OK - which appears to be the case .

1 Like

Really awesome jim. Thank you so much this is really great!