My try with Rhino render - for comparison

Reference: My try with Bella


My main gripe here is that it doesn’t give me enough bounces inside the metal cage. Is 64 bounces not enough ?

Also, the emitter just doesn’t get any brighter. Anything over 20 has no effect (and I have it set to 200).

The blue “Power ON” emitter at the base doesn’t show at all and it’s light does travel in the glass by much.

In other words I am not able to fully emulate this look:

Checking the emission strength setting with the simplest and clearest setup (black bg, no skylight, no custom environments) so that only emissive material lights the scene I get

If you want me to have a deeper look into your scene you can share it with me using

1 Like

I set mine to 1000. The preview scene changes, the actual scene has no effect. Same with the numeral emitter. They both max out like so no matter what values are in the material.

On what Rhino 7 version are you currently?

Version 7 SR7
(7.7.21160.5001, 2021-06-09)

Hmm, I haven’t made any changes to emission handling code between 7SR7 and 7SRC8 (which I’m testing with at the moment).

Here as an extra test, now with a skylight enabled

Note that you can type big numbers into sliders when you double-click in them. At least for light energy you can go well over 1000.

Here I set the number 3 to 100,000 and does absolutely nothing.

Does the Raytraced view restart after you have made you intensity change?

No not always, but I go back to wireframe and back to raytrace and the emitter has no effect. I render and it has no effect.

Please share your file using the link I posted earlier. I can have a look tomorrow. Without it I can only try to guess at what is going on.

Thanks for sharing the file, makes it much easier to see what we’re talking about.

First things first: although objects with emission materialcan be used to light the scene they are not yet understood by Rhino as lights (not accessible in the lights panel). As such Rhino thinks with your scene there is no light available at all, so it adds the socalled camera-based light that is looking towards the middle of your scene from over the left shoulder as it were. For now either add a point light with intensity set to 0, or enable skylight with intensity set to 0. A stupid workaround, but it is related to the YT item I linked you to yesterday in your other topic exactly on this.

With that out of the way I see this with your scene when opening

Further more there is a bug when there are many surfaces with an emission material assigned where the surface area and energy distribution doesn’t go always correctly.

With all emissive surfaces hidden and just leaving the blue LED set to ~10 strength and the numeral to ~16 I get


(I changed your backdrop surface material to light brown leather since your file had textures missing.

It’ll take some tweaking with the current engine version to get better response like that. Also note that Raytraced/Rhino Render doesn’t do caustics like Bella and other engines, so lighting through glass like this will always be less great.

In the end I removed all lights and used Christmas Photos Studio 02 1k from (Christmas Photo Studio 02 1k.renv (1.9 MB)) as skylight. Here Numeral emitter is set to 5.6 and the nixie base is also set to 5.6

I do think that here HDR Light Studio would be one of the better lighting solutions without having to place actual light emitting surfaces or lights in the scene.

Here a quick setup with some studio lights dropped into the environment using unlicensed demo

1 Like

Nathan, thanks for taking the time to share your findings here.
Yes, there was a point light initially hidden behind the backdrop to trip the engine into compliance, but I must have deleted it at some point during all the tests and trouble shooting.

My take-away from all this is that I hit the limit of how many surface emissions the engine can handle without getting confused.

By that you mean it does caustics “differently” ? … or doesn’t do them at all ?
Do the ray bounce settings have any effect and how would you set them optimally for this scene ?

Thank you for this suggestion, of course it’s a sensible workaround. My studio setups are years of Maxwell habit and in this case this scene started as a personal curiosity of how far RhinoRender has come since I remember using it many many years ago. So, I wanted to see a direct comparison, not merely ANY render that looks good :slight_smile:

This - no proper caustics.

They do. For more information check this: Light Paths — Blender Manual

Ok, so the Rhino help file on bounces is basically a copy of the Blender help file, but it still vague. It doesn’t give me an idea of optimal numbers for a scene. Is 12 bounces appropriate ? 32? 64? 128? 1256? At which point we get asymptotic diminishing returns ?

You should try using the smallest values that give you good results. For scenes with glass and metals in you want glossy, transparent and transmission bounces set to something like 16. Diffuse bounces 4 often is enough.

1 Like

The good new is, that if the emissive surfaces limitation is worked out, the result is decent and only a ten minute render.

1 Like

Wait a sec, I just realized you pointed to the Blender help pages, so the entire Rhino render engine is actually Cycles ? … not just the viewport renders ?