Rhino 8 Metal Render Quality

New-ish to rendering in Rhino so I’m not sure if this is just a setting I need to adjust or a bug:
Metal in V8 has been lightning fast, but the quality of the image seems inferior to exact same files rendered in V7 (shadows missing / washed out). Experiencing same Issue across different model files, on both i9 MBP and M2 Max Mac Studio, and in both Raytrace display mode + render. Examples of V7 vs. V8 below – identical render settings (150 passes) What am I doing wrong here?


If you’re using emission materials for lighting then that is something we’re currently working on to fix, there are some bugs that make it hard to control those.

If you are not using those then if you could share the file with me that’d be great for investigation and comparing to see what the potential bug is.

If you don’t want to share the file in public you can use Rhino - Upload to Support - I prefilled my email address for you, I’ll be notified automatically when the upload completes.

Thanks for the quick reply Nathan. Happy to share the file, please see link below:

You’re not doing anything wrong, essentially between Rhino 7 and Rhino 8 there are two different render engines.

I’ll have to dive deeper into why this happens, at the moment I don’t know.

edit: it does look like the skylight is coming through stronger. Maybe tune it a bit down for now?

1 Like

Thanks Nathan, will do that for now!

@KCXYZ is this originally a VRay scene, or is there data in there that comes from a Rhino file that has VRay enabled that you know?

Does this scene render as expected on your end?

i also had the feeling that renders are generally far brighter in v8, maybe since the engine is tuned up in some sort, that the bounces needed might have to be throttled significantly? just guessing of course.

I looks that in this particular scene, the groundplane is turned on when the scene is opened in V8. If you happen to run into a (simple) scene that does exactly this, it would be helpful to share it.

Thanks Gijs!

  • This was never a VRay scene – it may have been rendered in Windows at some point but otherwise was built + rendered in Rhino MacOS.

  • The scene you uploaded was much better! The more refined shadows are back, though all the textures were missing so I’ve been relinking them one folder at a time. My first few test renders below. Can you share what you did to fix it? Might try on my other files that seem to be having similar issues.

  • New / separate issue: I got an “system has ran out of application memory” warning from macOS as I’m relinking the textures that shows Rhino using 150GB(!) and forced me to quit / reboot machine (M2 Max Mac Studio with 64gb ram). Happened a couple times so far. Screenshot of warning window also below.


Will do!

Something similar happened to me a while back, and it was related to the Intel Denoiser… but there have been many WIP and Beta builds since, so your issue may well be unrelated.
Worth checking though.
[Here also on M2 Max]

Akash

Sorry for not sending the full scene.
But you don’t really need it. As mentioned your file once opened in v8 turns the groundplane on which wasn’t on in the original v7 scene.
Turn that off and you should get a proper rendering in v8

2 Likes

Forgot to confirm that this worked:
Opened V7 model in V8 beta; turned off Ground Plane in Render Setting; rendered as expected.
Thanks again!

We have narrowed down the code where this is happening. When it is fixed I believe this topic will be notified as well, since I added a link to this in the bug report related to this.

1 Like