My Rhino 6 viewport display keeps freezing

This is a problem I have been having for a long time ever since I imported some display mode options. It freezes randomly. sometimes every 5 seconds. sometimes after restarting my computer, it doesn’t freeze at all.

I recorded a video.
http://youtu.be/FtzWnYi7Ilw?hd=1

My system info

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: T080001

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 5-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.86

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2019
Driver Version: 26.21.14.3086
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

More infos:
My graphic card driver is updated on 26/5/2020.
most up-to-date driver

I suspected it has something to do with my imported Options and Display Mode.

When I transitioned from Rhino 5.0 to Rhino 6.0, I also imported the Rhino 5.0 options to Rhino 6.0.
I can replicate this freezing problem in different computers every time I import these Options.

But it’s a bit too painful for me to rebuild these Options and Display mode… The Toolbars and Options file have also been uploaded.
Can anyone help me identify the problem?
IWileyTemplate.ini (404.0 KB) default_B.rui (17.6 MB)

Not according to the SystemInfo above:

The latest NVidia drivers are 450-point something.

If updating the drivers doesn’t stop the freezing, then maybe, yes, one or more of the display modes imported from V5 are corrupted… In that case, I don’t see any way out other than making one or more of them from scratch in V6 and deleting the old ones.

Is Rhino fully Unicode, to have more than one language in the configuration files?

        <locale_1033>Curve Drawing</locale_1033>
        <locale_1031>Kurvenzeichnung</locale_1031>
        <locale_1034>Dibujo de curvas</locale_1034>
        <locale_1036>Dessin de courbes</locale_1036>
        <locale_1040>Disegno di curve</locale_1040>
        <locale_1041>曲線作成</locale_1041>
        <locale_1042>커브 그리기</locale_1042>
        <locale_2052>绘制曲线</locale_2052>
        <locale_1028>繪製曲線</locale_1028>
        <locale_1029>Kreslení křivek</locale_1029>

Hi @Brenda @Helvetosaur
Thank you for your help!

Do I remake the .ini file or the toolbar file?
I suppose the toolbar setting file is okay?

and does it make sense to the developers that a corruption in the .ini file may lead to rhino freezing constantly?

Do update your video driver first before doing anything else and test to see if the crashes still happen.

The toolbar file has nothing to do with the display modes. Are you saying you imported a .rui toolbar file from V5 into V6? The conversion is automatic and normally OK - hopefully you are not sharing the exact same .rui file between 5 and 6 (not even sure that’s possible). It is of course possible that a corrupted toolbar file might cause random crashes, but usually, it simply refuses to load at all.

As far as the .ini, I would not mess with that directly - too much of a chance of making a mistake - I would suggest starting directly in Rhino>Options>Views>Display modes and making copies of a standard V6 display mode (not imported) and then modifying them directly. Delete the imported ones (at least the ones you may suspect cause crashes).

The .ini file is probably not ‘corrupted’ - it may be that some display setting in V5 is not compatible with V6 - and maybe Rhino was not able to sort it when it read the .ini file on import.

It is also possible something entirely different is causing the crashes, but difficult to say without eliminating the most likely causes first.

Hi,
As i could reproduce the crashing event in 4 different computers, I am pretty sure it has to do with the custom ini file. Whenever I import my precious V5 settings and display mode, it becomes unstable and crashes randomly. Sometimes it doesn’t crash at all.

I want to revert my V6 Rhino to the default settings, ini is there a way to do it that doesn’t involve reinstalling? can i download a ini default file from somewhere?

For the display modes, if you want to reset to default, I would just go in and delete any custom display modes you imported, then with each of the standard modes left, go into the mode and punch the “Restore Defaults” button. If that doesn’t stop the crashing, then it’s something else.

Did you update to the latest drivers?

Yes. I have updated the driver. The problem persists. I will try to reinstall Rhino. My option file affects not only the display mode but also other things I believe. I will rebuild the options and update here after.

Your display mode WileyTemplate was built on Wireframe, the only thing I think may be involved here is the custom curve thickness in relation to the Anti-Aliasing setting for your Rhino in Options > View > OpenGL. Try reducing the AA setting there if you still have an issue. If that doesn’t help, please post the latest SystemInfo from your Rhino 6 and also a sample 3dm please that you can use to reproduce the hang you showed in the original video.

Hi Brian James.

I plan to reinstall Rhino and rebuild the option file after the current project ends.
But following your advice, I reduced AA from 4x to 2x and I haven’t experienced any hang since yesterday.(normally it hangs like 3 times a day randomly). I will give it a few more days and provide an update later.

Sounds good, it’s smart to not make system changes when in the middle of a job.

My hunch is that the AA and the display resolution are factors here in what you’re seeing. The GPU and it’s drivers are variables too of course as well as the file itself. I don’t think the .RUI file would be a factor.

Hi Brian,
reducing the AA definitly helps, but it still doesn’t eradicate the crash event. In these last three days, I have had two similar freezes. After that another recent freeze, I just set the AA to None. Is it the only solution? or should I update my display card setting?
More about my modelling habit: When I am modelling, I like to apply display mode to specific object so I can see them in a different shades/ or curve width. (e.g. ! _SetObjectDisplayMode _Wireframe)
While this is my favorite trick, it also makes the software unstable.

I also use a dual monitor, and again, the hang can be reproduced whenever import the settings into a new computer,

There are a number of variables here in addition to the AA setting. I’d also try checking the resolution on the second monitor and making sure it is set to the recommended resolution Windows 10 wants to use. I’d also try making the second monitor the primary display. I would also test if you have issues without the second monitor, this will tell us if it is a hardware configuration issue or not. I’ll need to see you current system info to suggest any driver update.

Also, you mention crashes but I think you mean freeze or hang, correct? If Rhino actually crashes and you get a crash reporter, did you send that in with your email?

freeze or hang.
Yes. I meant that. I have replicated this freeze on computers that have just one monitor or dual monitor. I have tested it in a number of computers already.

This is the systemInfo

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DE-PF1511Z2

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P3200 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 9-4-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 399.21

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-30-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-4-2018
Driver Version: 24.21.13.9921
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Users\CWAI\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.4.13.574\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Update your graphics drivers for both cards in the computer. Use the Notifications panel from the Panels drop down menu in Rhino 6 to get links to the manufacturer driver download pages for both. You have two GPUs in this one so make sure to update both drivers.