Multipage Rhino PDF always raster

Trying 8.2.23325.14001 now and it seems that most issues have been solved for me, page sizes, line widths etc. are correct both using Adobe PDF and Rhino PDF. The latter has much cleaner vector output and also seems faster, Adobe PDF hangs for some time during the export. It also doesn’t have the issues I used to have with RhinoPDF before (at least in Rhino 6), like incorrect linetype scale, chopped up corners…, so it’s now usable.

Edit: Rhino now also remembers (after closing it and reopening) last used page size, although just like R6 it still doesn’t remember View and Output Scale section settings (except when I set it to Window, then it seems to remember that). But it at least remembers it during single session which I think was also broken in the 8.0 build.

The only big issue is that when printing multiple layouts using Rhino PDF, the output is completely rasterized, like the whole page is just one big JPEG image. When printing a single layout, output is correctly vector. (Adobe PDF prints vector both when setting single and multiple layouts.)


Are you still seeing this. We’ll need to try and repeat this bug.

Thanks @stevebaer ,

I’m testing the dujour build you shared in the other post and so far it’s working great with Rhino PDF for single layouts at a time, multi-layout batch export is incorrectly exporting everything as Raster but it at least is to scale and giving me the sheet size I expect so thank you for sharing and the team for getting those parts fixed!

1 Like

Are you still seeing this in 8.2? I think this bug might have been missed in the previous thread and I want to get it on the buglist if it is still there.

I believe this was working last I checked, when I’m back on I’ll confirm

1 Like

1- Using the new print dialog Box, I always get Raster instead of vector when printing multiple pages.
2- Using Legacy print dialog Box, I get vector output.
I’m running Rhino 8 SR3 2023-11-28 (Rhino 8, 8.3.23332.06001)

BTW nice touch:

1 Like

ok, thanks. Bug logged at


@stevebaer this is the case on my testing as well in 8.2 release candidate build

I do get multi-page Vector PDF when using AdobePDF or Bluebeam PDF instead of RhinoPDF.

Yep, as I said, this was using version 8.2.23325.14001 which Rhino claims is still the newest RC.

This bug was fixed today. It’s headed to testing now.


Just tried SR3 and can confirm it’s fixed.

(Unfortunately, another serious bug was introduced that forced me to downgrade back to SR2.)

1 Like