Mouse jumping in layer panel


I have an issue with the layer panel when trying to window select multiple layers.
When I want to drag a window selection from the bottom right, upon the first click my pointer jumps to the monitor bottom right corner.
here’s a recording (only the rhino window was captured)

I noticed I have the same issue with my fileexplorer ( freecommander) and found a topic about it, where it is suggested this issue was introduced with the infamous windows 10 FCU
Here’s a link, notice the post with the animation also displaying what I experience in the rhino layer panel.
Not sure if this is something to be solved by RMA or Microsoft but I thought it best to report it anyway.

Edit did some digging:
It is stated to be related to the horizontal scrollbar being present.

Hi Willem - I’ve had one other report of this ( I now realize, it was not well explained) and it does not happen here with plain Windows, no utilities. Hm looks like Freecommander is 32 bit unless you pony up… is that what you’re using or is it the 64 bit version?


Hi Pascal,

I’m running FC 64bit ( donor version)
See my additional links where it’s reported for other apps as well.
I’m running Win10 PRO


Hi Willem, so far I do not see this in 7Zip, if I am doing it right, either…


I see the behavior here as well. It indeed happens only when the horizontal scrollbar is visible. When I size the panel such that the scrollbar is no longer visible I don’t see it happen anymore.

Do you have any of the extra software installed, or is it with just Windows and Rhino?

This doesn’t looks like a bug to me.
It looks like a handy accommodation to selection in an undersized panel.

If your first pick for the window selection is in the center of the panel, then drag your mouse to the left or right side of the panel, and the view shifts to see that side of the panel. You can essentially “pan” in the undersized panel while window selecting.

I do have some other SW installed, would you think this is relevant?


Hi John,

Actually the mouse jumps out of the panel and application to the corner of the desktop. If it’s mean to be a feature It’s a crappy one.


Oh, that I don’t get. Only the jumpy behavior of the list scrolling instantly to the one side.

Same here, the pointer doesn’t leave the application.
Are you running maximized? I’m not. Do you have multiple Rhinos running? I don’t.
When I get in to the office I’ll try a few things but @Willem, I need you to try to narrow it down too


No, windowed

No Just One

Let me know if I can test anything else.

Do you and a different mouse you can try?
Do you have Rhino installed on another computer? Does this happen there too?

The point is if we can’t repeat it we probably can’t fix it.

Oho, I do get the jumping mouse now. At first only with Rhino 6 maximized, but now also with it un-maximized. The jumping happens wherever I have the layer panel docked, even when it is floating. As long as the horizontal scrollbar shows it happens.

I am now not sure if it happens because I had a 7z-manager open at some point or not. I’ll have to let the current regression test run (close to 1000 renders) and restart the machine to see if I can repeat it still then.

Hi John,

I see @nathanletwory is able to reproduce it. Does that mean you can reproduce it?

As for your additional questions:
I have a roccat KIRO mouse, I have no other Rhino running on a Win10 system.


FWIW, I can’t repeat over VNC, so any further attempts to reproduce will have to wait until tomorrow :confused:

I’m having problems repeating it here now too, and never did get my pointer to jump out of the panel.

Do you have a plain wheel mouse you can test with?
So far, your special mouse seems to be the biggest difference in your setup.

Hi John,

I just tested with my laptop’s trackpad: same behaviour.
I’m out of options what to try.

After my online research on the issue, I think it not related to Rhino specifically, but rather an issue with the FCU, where something got broken for this specific case and with code that apparently is not used widely enough to cause more outcry.

Let me know if you want me to test anything else.


What is “FCU”?

At this point, since we can’t repeat it, there’s nothing to fix.
I’m sorry it’s so annoying.
If you or someone else comes up with a way to repeat it, then we can fix it.

I’ve tried on two other systems and so far I can’t repeat it.

FallCreatersUpdate for Win10
in a link I posted in my original post, someone experienced this behaviour only after that update.

someone else with the same isse:

I have the issue also with the the registry editor (regedit.exe)
Same behaviour like the other people in above linked thread.

Maybe we have to wait for @nathanletwory until now he was the only other person over here who could replicate the behaviour.


Maybe this reply from the forum post linked above can give the developers a clue where to look or how to replicate: