Erratic curser behavior when selecting multiple layers

unhandled

#1

Hey I just noticed what I assume to be a bug. I looked around the forum a bit but didn’t see anything like it so I will mention it for what it is worth.
When I drag my curser in the layers panel to select multiple layers at one time, the instant i click and start to drag the curser snaps up to the top right hand corner of my screen. It does select everything but it is a little disconcerting especially when I am only planning on selecting 2 or 3 layers.

Thanks!


(Nathan 'jesterKing' Letwory) #2

There is somewhere an older thread about this. I’ll see if I can find it.


(Pascal Golay) #3

Hello - I think we have run into this before and I think there is a Windows or mouse driver setting that makes it so that the cursor goes to some default location- I’m really on thin ice here, but as I recall it is not Rhino doing this directly. What version are you running, and what Windows and video card? If you’re in V6, run SystemInfo (Help menu) and paste the results here…

-Pascal


(Nathan 'jesterKing' Letwory) #4

#5

I kinda suspected it was an isolated problem with me since I didn’t see anyone else mention it anywhere. Here’s my system info…

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 8Gb)

GeForce GT 635/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2018 for R6\RhinoCAM 2018 For Rhino6.0.rhp “RhinoCAM 2018 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2018 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


#6

That is exactly what is going on so it seems to be a windows problem. Is there a way to fix it or do I just wait for Windows to fix it sometime? It’s not debilitating just annoying when I forget it :slight_smile:


(Pascal Golay) #7

I wonder if the setting in Windows to zoot the mouse pointer to the default location might control this:

-Pascal


#8

It didn’t seem to make a difference to change the mouse settings. As far as I know my computer is kept up to date automatically, but maybe I’ll poke around with my settings and see if something can be updated or changed. I’ve never noticed it with any other software, but I don’t know if that means anything.
Thanks for y’all’s help so far!