Modified object parameters, lost other editable parameters


#1

Easy in BO-1, parameter editability lost in BO-2.

I added the ability to modify an object, but now ONLY the VISIBILITY parameter appears when I select EDIT KEYFRAME. I ALSO need to do other things to that piece, like move it, rotate it, etc.

Any suggestions helpful.

Thanks -

C.


#2

The whole Edit Keyframe dialog is screwed up.

For a selected object you cannot specify any new properties unless you first fiddle with entering a value down in the Time Line while in Animate (recording) mode, then the property becomes available so it can be edited. .

It slows down configuration work very very much. Needs to be fixed.

// Rolf


#3

Rolf -

SO- make ANY change to ANY parameter, and lose the ability to change other parameters in the dialog box, unless you fiddle it blindly at the Time Line ?

I’d hoped to FOOL BO-2 into “hiding” the HIGHLIGHTS that SHOULD go to TRANSPARENT-100 with the rest of the part, by changing the visibility to OFF at the last moment before the next tick-mark, but have lost ALL other changeability because I SUCCESSFULLY changed the TRANSPARENCY to 100%.

This pretty much renders BO-2 useless in any meaningful way.

I went to the main BONGO page hoping to find a clue or maybe a pertinent example, but all I find is non-precision animation SHORTS not dealing with the PRECISIONS I got used to in BO-1.

Oh well.

I’ll call the client and tell him he can’t have what I’d hoped to deliver.

Thanks bud, and all my BEST to you and yours 1

-C.


(Marika Almgren) #4

Charles,

If you select the animation set, in your case where it says: Default
Please make sure you don’t have Only show animated parameters checked.

If you have the checkbox checked Bongo will only show you the parameters you have animated.


#5

Marika -
Thanks. This will help. Interesting note, however - once I check this and discover the check-box “checked” (as anticipated), since I did not set this I’m guessing this is the default. Is that appropriate ? We set a setting, and that intentionally disables visibility of all other settings ?
Also, the reason this came to my notice was that I had set the visibility of the material to fade to 100% but the HIGHLIGHTS remained. Is THAT right ? Shouldn’t THEY have been 100% “invisible” too ? Do I have to dig for another hidden variable checkbox of some sort to deal with the fact that a material has highlights ?
I’m hoping that if so, just clicking the INVISIBLE check box at the end-marker will handle this, but shouldn’t it be handled by the 100% Transparency setting ?
Thanks -
C.


#6

Wow, that little checkbox made an incredible big difference to my workflow!

I didn’t know I could expect it to exist, and so I didn’t even ask for it. Showing all properties should be the default setting.

Anyway, thanks!

Edit: I guess this is one of the problems with spreading out (general) settings in different context - then it’s no longer “general” and users tend to not discover things intuitively. As a Bongo newbie I had a somewhat similar problem with Align Pivot since the Move Pivot icon was located in the main Bongo panel and in the Bongo Properties panel (see picture), while Align Pivot (or “Rotate Pivot”) icon only exist in the Properties panel. Problem: New users see one icon (in the main panel), and then the other icon (Rotate pivot) seems to have disappeared, or not even exist, since you intuitively expect both the Move and Align pivot commands to be accessible from the same context(s). The property icons come and go as you click objects and ther4efore you don’t pay as much attention to it. Kind of the same problem with the Keyframe Editor. General settings should not be accessible only in specific (in context) situations, then you tend to miss it.

// Rolf


#7

Rolf -

Yeah, I asked about this as a “default” setting. I’ve wondered about similar things in the past, but have never gotten a good response without being a little annoying to get it far enuff to get an answer ! Ok, best to you -
C.

Marika -

I’ll check this and let you know if that was it.

Thanks !

C.


(Marika Almgren) #8

Showing all properties should be the default setting.

The setting is unfortunately on by default, if I remember correctly it was so by customers request.
I’ll list this as a bug and we’ll get it fixed, clearly having it on by default wasn’t a good solution.

I’ll also log the the stuff you pointed out as a bug.


(Marika Almgren) #9

Charles -

Also, the reason this came to my notice was that I had set the visibility of the material to fade to 100% but the HIGHLIGHTS remained.

If your material has glossiness and/or reflection you need to put those parameters to 0% order to make sure your material is completely invisible.