Model disappears in some views

Hello,

I have problem with strange Rhino 5 behaviour. I’ve linked a 3ds model to Rhino file and the model at first appeared in all views except perspective view. I’ve tried to turn on perspective view in another view window to check wether it will solve the problem. However, it disappeared there as well and going back to right side view did not help either.

Is that a bug or am I doing something wrong ?

Regards,

Hi m_ziolo_8

Can you attach the files? It’s probably easier to track down the cause.

An unrelated Question:
I see you have a scale ruler indicating the size of 10cm
Is that a feature from a plugin, or a setting inside Rhino?

@Willem, here you go. Scale Ruler is the feature of VisualARQ plug-in for Rhino. I attach two files - you have to link 3ds file to Rhino file.
Here is the link: https://www.dropbox.com/s/mmsomf337k000av/Bug%20Rhino.rar

Hi,

There is definitely something wrong with the 3ds file.
The first thing I noticed is that there is a directional light inside that file that is
for some reason represented as a huge object.
However still,
@pascal When I open the Building3DS.zip(46.1 KB) by itself in Rhino, I can select and delete the directional light named “sun”
However, the remaining mesh objects will not zoom extends when selected (only in the perspective view it does zoom extends).
m_ziolo_8 To fix the 3ds I did this:
Open the bad 3ds, delete the light object named “sun” and exported the remaining objects (house) as 3ds.
That 3ds:Building_2.zip(31.5 KB) behaves as expected.

HTH
-Willem

By the way, @Willem, have you noticed viewing issues of the model in perpendicular views?

In perpendicular views elements of the model seem to be transparent and you can see elements on the other side of the model, while in perspective view everything seems fine. Of course, I don’t mean wireframe mode, where it is obvious, but check out differences in front view and perspective view on the attached image.

Willem, I made a python plug-in that puts a ruler on screen- shout if you want to give it a spin. It works reasonably well (here), but the difficulty in installing Python Plug-ins reliably has made me hesitant to send it out… Oh, also, it is dependent on getting each particular display’s dot-pitch right. There is a setting in it for dot pitch but you need to know it. The way I have it now, the ruler is always the same length on screen (pixels) and its measurement in model units changes according to zoom.

-Pascal

I guess for now I would open the 3ds file in Rhino, delete the light and run 4View, twice in a row to reset the viewports- then link that file to Rhino.

-Pascal

your plugin sounds interesting and very helpful for modelling ! May I know whether there is a version for Mac Rhino?

Hi li1 - here’s the python script

ruler_PG.py (10.8 KB)

So far I am not finding it works very well on the mac - when I turn it off the views go all white… In any case you’ll need to set the dot pitch for your monitor when you run it, see pxcalc.com

-Pascal

1 Like

Super thanks!!! :wink:

Hi,

I have the same issue on Mac Rhino 7 (7.6.21127.19002, 2021-05-07), where sometimes, I realise some, not always all, objects have disappeared in top view, while they still appear in perspective view. I tried resetting “4View”. The only way I found to have them showing up on screen was the clumsy trick of duplicating the layer and deleting it. But you have to rename it, re-assign it a colour…


emphasized text
Any ideas? It’s funny to see a similar issue 4 years later.
Regards,
Georges

Disappearing object.3dm (87.8 KB)

Hi Georges -

The issue that is the topic of this thread was reported 8 years ago. Someone merely asked for a script 4 years ago. When so much time passes, it’s safe to assume that your issue is something different altogether and you should just start a new thread.

That said, some early versions of Rhino 6 on the Mac made it possible to turn off object and layer visibility in a specific viewport in model space. On Windows, that has always only been possible for details on a layout and this was fixed on the Mac at some point.

In your file, the Top viewport has display of the “Palestra” layer turned off and any objects that are on that layer will be invisible in that viewport. The file behaves the same way when it is opened on Windows. On Windows, you can solve this with the CloseViewport command and then creating a new Top viewport. That command doesn’t work the same way on the Mac and you must use the new layer work-around. The alternative is to go back to the Rhino version where this viewport was turned off for that layer and turn it back on…
-wim

1 Like

Hi Wim,

Thank you for your quick answer.
First: let me correct my tone, I didn’t want to sound sarcastic, I was genuinely curious… I’m starting a new thread following your advice.

I checked on the file and found the layer on, are you referring to something else…?

I thought it might have to do with the Layout and layer detail information panel, but in this small file there is no Layout setup.
So I went back to the big file where I have the whole model (the one I shared here only contains the blue exported volume), and fiddled with the layout, but there the layer was active, and the issue was still the same…

I’m not sure I understand fully: I should go and “recover a previous version” of the file through my back-up system until I find a version where the objects were displaying correctly? Or should I try to install Rhino 6…?
Either way, I’m not sure I know how to turn off a viewport for a layer on the modelling window. I know it can be done in the layout window, but the objects show up fine there…

… Finally, I seem to remember I once managed to get the Layout and layer detail information panel showing up in the main window, as I wanted to see different things in the respective views, but I can’t get it to show up anymore…

Georges

Hi Georges -

Yes, I’m referring to something else.
The setting that you are looking for no longer exists.
It used to be possible, on the Mac, to turn off a layer in a model space viewport. This is no longer the case. When this was fixed, the fix also meant that you can’t “repair” a viewport that is in that state.

You can’t - not anymore.

That’s part of the issue, yes.
I now found more information about this.
The layer panels on the Mac were redone in Rhino 7. In the early versions (7.0 through 7.3), it was possible to see the layer tree in the Layout and detail layer panel. It was here that it was possible to turn off a layer while a model space viewport was active.

To fix this on a Mac you have the following options:

  • Move the objects to a new layer
  • Open the file in Rhino 7.0 - 7.3 and turn the layer back on
  • Import the file into a new file
  • ExportAll to a new file

-wim

1 Like

Dear Wim,

Oh my goodness!

This explains everything… I could have never imagined that to be the cause. I liked having the Layout and layer detail information panel in the modelling window in order to work simultaneously on insides and outsides of buildings (I use Rhino for Architecture) but hadn’t explored that workflow much yet.

Thank you for your advice: I didn’t make it with ExportAll, but importing the previous file in a new file was swift and simple. I also separately imported the CPlanes…

Now the model is back to normal and all objects show in all viewports.

Thank you so much for your precious time and much appreciated advice and research!!!

Best regards,

Georges

A very grateful masterplan project showing well again :partying_face: :

1 Like