Mixed Vector Raster Print Issue After Latest Update

rhino

#1

Has anyone else experienced issues printing a PDF with mixed vector/raster in the layout after the latest RH6 update? I’ve been printing a particular file just fine, now it crashes as it’s saving the PDF. I tried using a couple different PDF writers and re-inserting the images with no results. The same file prints fine without the image.

Thanks,


Raster image not showing up on print
#2

Here’s the log:

%%[ Error: syntaxerror; OffendingCommand: --nostringval-- ]%%

Stack:
/definecolorrendering

%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%


(David Eränen) #3

Hello @jtrudeau,

Did you see a crash dialog for sending in an error report? I can find one crash report from you from 4 days ago. Is that the one?

Would you be able to send me the model which is crashing for you? Either attach it here or send it privately to https://www.rhino3d.com/upload.

Thanks,
-David


#4

Hi David, I don’t think that crash report is the one since this problem started yesterday after i downloaded the update. Let me check with work and see if I can send overt the file. I’ll get back to you shortly

JRT


#5

Instead of uploading the original file I just made a test file using an image with line work and it also crashed when trying to print a PDF. I attached the file and image.

log still says:
%%[ Error: syntaxerror; OffendingCommand: --nostringval-- ]%%

Stack:
/definecolorrendering

%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%

tEST_fILE.3dm (999.9 KB)


(David Eränen) #6

@jtrudeau Thanks,

Can you paste the text from Help -> System Information...?

-David


#7

Here ya go:

Rhino 6 SR4 2018-4-10 (Rhino 6, 6.4.18100.1591, Git hash:master @ b6485d60ae29d5ee76751120dc9232f8b172e934)
Licence type: Commercial, build 2018-04-10
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 7 SP1 (Physical RAM: 64Gb)
Machine name: WINTERMUTE-PC

GeForce GTX TITAN X/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2016
Driver Version: 21.21.13.7633
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

C:\Users\Wintermute\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Auxpecker Studio 3\AuxpeckerStudio3.rhp “AuxpeckerStudio3”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(David Eränen) #8

@jtrudeau,

I’m not able to reproduce the crash using the same Rhino version. I would recommend you update your GPU drivers since they’re 1.5 years old. Let me know if that solves your problem.

-David


(David Eränen) #9

@jtrudeau,

If that doesn’t solve the problem, please post a screen shot of your PDF printing settings so that I can be sure I’m testing the right thing.

-David


#10

Hi David, I’m already using the most up to date driver- 391.35


(Pascal Golay) #11

Hello - I’d ask the nVidia website - Windows driver checker is almost certainly lying. Looks like there are Titan drivers from Maach 27.

https://www.geforce.com/drivers

-Pascal


#12

Hi Pascal, that’s the one I’m using, 391.35 from March 27th


#13

Maybe that’s the issue, I’m going to try re-installing the driver and get back to you


#14

@pascal,

So I reintsalled the drivers and windows device manager shows the correct driver but Rhino System Information is still showing the outdated driver. Not sure if this has to do with the problem I’m having. See below.


(Pascal Golay) #15

Hmmm - It might be worth doing a ‘clean install’ (i.e. remove then install rather than install on top of…) of the driver.

Here is some info:
https://help.ea.com/en-us/help/pc/how-to-perform-a-clean-installation-of-your-graphics-driver/

-Pascal


(Steve Baer) #16

Your crash looks more PDF related that video driver. Which PDF printer are you using when printing?


#17

@pascal,

I did a complete uninstall using Revo then reinstalled the drivers. It did show up as current in my Rhino System information but unfortunately it didn’t fix the issue

@stevebaer

This happens with Adobe PDF, PDF995 and Rhino PDF


(Steve Baer) #18

I just found a bug that may be related to this in PDF printing. Working on a fix for it right now.


#19

That crash report might have been coming from me…

I was trying to print some AO shader with an Acad imported plan on top. Was using a Surface Book with Nvidia Gpu at that time.

Tried with Rhino PDF, Adobe Pdf and Microsoft print to PDF drivers.

the thing which was a bit shocking was that the when using Adobe pdf the entire Computer locked up.
Meaning I could not even restart… Task manager showing 100% CPU on “system interrupt”

Had to hard shut down via Power button a couple of times!

When using Rhino PDF small resolutions would sometimes work bur higher res came out as a blank PDF.
Which oddly still had a filesize of 500kb or so.


#20

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GTX 965M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.08)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-19-2017
Driver Version: 23.21.13.8808
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”