Missing geometry, unexpected geometry when upload gh script to ShapeDiver

I’m trying to upload my script to ShapeDiver, but there are missing parts of my geometry once uploaded.
And there are some geometry that don’t exist in my script showing up as well.
Has anyone encountered the same problem?

I tried to internalize the geometry and upload again, then it works!
Then, I internalize the geometry part by part, step by step, to check where is the mistake in my script, so far, I have no clue.
See below images. The 3rd image, showing something doesn’t exist in my script:(

Please share your insights!

Which version of Rhino and of the ShapeDiver plugin are you using?

Hi, thanks for your fast reply.
I am using Rhino7 with ShapeDiver 1.9.

Some more information to explain what I have experienced, a model/script (let’s call it AA)I uploaded successfully a week ago, was working perfectly. And it’s still working on my dashboard.
Then, today, since I’m having problems of missing geometry, I upload the same ‘AA’ model/scrip again, it appears with missing geometry.
I was wondering what would be the explanation.
Please share your ideas or any suggestions.


Your question reminds me that I should open my GH script with Rhino 6, instead of Rhino 7.
And the script doesn’t work well in this case, one component is not functioning well, which is ‘‘curve offset’’.
But with Rhino 7, this problem didn’t show up.

Even though opening script with Rhino 6 didn’t work well, it helped me to understand why I have some unexpected geometry showing when I upload to ShapeDiver. In Rhino 6, I got the same weird geometry as my last post. I thought it didn’t exist in my script, turns out it can be there if opened with Rhino 6.

Anyone has any ideas?


Since you mentioned a problem with the Offset function, I ran into some issues when not using an explicit value for the Plane input in the Offset component - see here: https://discourse.mcneel.com/t/misbehaving-offset/129341/10.

Hope this helps…


Hi Marco,
Thanks so much for your help!
It works, it solved my problem. Now there is no missing or unexpected geometry :slight_smile:

Unfortunately, this is one of the small breaking changes between Rhino 6 and Rhino 7. Thank you for the help Marco.

Happy to help :slight_smile: