Mesh split for sneeze cfd not working


We are trying to make a few cfd of a sneeze for research correlated to COVID 19

on this purpose i was trying to split a head triangulated mesh thus in order to create the inlet mesh for the mouth.

to be honest i have already done it once by using ( if i am not wrong ) “Meshsplit” command and everything was working just fine. ( pic 1 : head mesh + cutting srf / rpic 2: desired result )

now i a trying to split same mesh with same splitting surfaces by using “Meshsplit” command and I am not able to split the mesh.
to be honest I am not able to remember if i using something different from Meshsplit command but i am quite sure this was not the case.

when i run the “Check” command the mesh seems to be fine

I am using RH7.

does anyone know how to help me ? this is correlated to a an urgent isue , if anyone can help to solve i’d be very grateful.

many thanks in advance


maybe you can use a nurbs head like you have here:

Hi Diego and thanks for your answer.

Point is the we only have meshes and we hase to use them cause it is much faster to modify the mouth shape and position by using mesh sculpting softwares.

We are not able to understand why meshsplit is so unconsistant. Or maybe we are doing something wrong.



The tools to try first before splitting are:
And then ReduceMesh with 1% (To 99% of original) just to rebuild it if the above doesn’t work.
Hope that helps.

1 Like

Or if you split once and then joined back and now want to split again, then try explode first. Maybe, if it was welded prior to splitting and you haven’t welded after, it will come apart again.

Hi Holo and thanks for you suggestions

i tried to

And then ReduceMesh with 1%
Meshsplit command

I also tried to triangulate after this but there is no way to split the mesh with the given srf…
point is that just a few weeks ago i splitted the same mesh using similar surface so there must be something wrong on my workflow. Maybe the Meshsplit command is not the one to be used? I am not able to remember.

the mesh seems to be behaving as single , unseparetely mesh , i wonder if there something similar to ungroup , unweld , explode commands or something else that need to be done to “unfreeze” the mesh.

or maybe i wonder if there is some issue with general tolerances or if it has something to do with latest release of rhino WIP

In case you guys are willing to give it a try i attach the file of the head + splitting surface + splitted mesh ot the mouth generated long ago

20200408 MESHSPLIT NOT WORKING 1.3dm (1.5 MB)

really hope you will be able to help us guys , right now we are stuck with no chance to perfom further cfd

many thanks in advance


Hi Ivan,

I had to make a new “splitter” for mesh split to work.
After some testing I tried splitting with other shapes and those worked fine so that lead to some exploration on your splitting geometry. (I don’t know why it failed though, @Jussi_Aaltonen is this something for you to look into? )

What I did was project a curve onto your splitting surfaces, join the projection and then extrude solid those curve. Then use them to split with and all went fine.

Good luck from here on.

splitted head.3dm (1.5 MB)

HI Holo and thanks a lot for you help

the sent file is exactly what i need but i am not able to obtain same result by repeating the given instructions.

here is a vid of me following your workflow , the mesh is not getting splitted by using Meshsplit command .

Am i missing something ?

many thanks


@Holo I’m not sure who could look into that. @piac can you or do you know who could?

Hi Ivan @cloudsvisitor77,

the MeshSplit command in Rhino 7 WIP is a new command. It’s being worked on, as explained here: New Mesh Intersection Milestones.

I think I know what’s going on. The inconsistency is due to something I am currently working on, called “the problem of resplit”. Once a mesh has already been split by a command, splitting it again gets even harder. If you run the _DeleteMeshNgons command, you’ll see the newly created ngons of the previous split. But something is not right here.

My guess is that you split the mesh with only ONE part, then tried to split it with both.

I would like to understand better why the split failed in the first place.
Do you have the model before the first split?



Giulio Piacentino
for Robert McNeel & Associates

1 Like

Hi Giulio @piac and thanks for your explanation

attached please find the one that should pretty much be the mesh i started from.


I am having the same problems also when i try to split other head meshes and meshes in general …what i can report is that i am quite sure i splitted the mesh attached to this message without major problems by using the WIP versions corresponding to period between December 2019 through late February 2020 and Meshsplit command.

I am not able to give the WIP version nr. but i have always promptly downloaded all new RH WIP releases ever since.
Hope the period can somehow give you some hint …what i can report is that , despite my little experience with the meshes , during this period i never had major problems to split meshes , the Meshsplit command was working just fine , or maybe i was just lucky…i dont know . I started to work with meshes again recently , 2 weeks ago i still made some successful mesh split but now there is now way to split any kind of mesh.

I wonder if this can somehow be due to some modification to the WIP engine ?

Hope you will be able to find a fix to this problem cause meshsplit is a very useful command

@Holo : I wonder if you are using the latest WIP version or a previous one



You are right, I had an old WIP that got updated when I closed it, I’ll check with the new build later.

1 Like

OK, I had rhino_en-us_7.0.20064.14095.exe installed on my system yesterday, and today with the new build it fails.

With projected curves refitted to 0.01 tolerance, extruded with a cap I get this faulty meshintersect:

As you can see it both selfintersect AND has open intersectcurves between the head and the nurbs.

And if I mesh the nurbs part first then the meshsplit just removes the head all together if I try to meshsplit.

In V6 FitCrv with 0.01 the curves prior to extrduding them into a solid lets me split the mesh just fine. Both with file tolerance settings at 0.01 and 0.001.

Hope that helps.
Remember you can Copy Paste between V6 and V7.

1 Like

I have some clue about what might have been added in this time period. I’m having a good check and will report back asap regarding V7 WIP.

1 Like

@Holo @piac thanks guys for your support and commitment, hope this will be fixed asap

@Holo good to know that you also found same problem with latest release , hope this consistancy in to the error will be somehow useful for Giulio and McNeel’s folks.

I also made several tests similar to the ones you suggest before posting the problem and found very similar results…discontinuos intersection curves and disapperaing meshes. it looks like the mesh intersection code is now failing.

the given solution i.e. using FitCrv partially solved my problem but for example it didnt allow me to split this “ugly head” here below with the shown line…spliting operation that was perfomed smoothly several times last month using Meshsplit and previous WIP version

20200410 MESH SPLITugly head NOT WORKING .3dm (2.4 MB)


RH-57855 is fixed in the latest WIP

1 Like

Many many thanks @brian and @piac for quick fixing.

i just tested latest wip and its now working perfectly again !

cheers :wink:


1 Like