Can't split a mesh

Hello, I am having a problem trying to split a mesh with a plane (that I previous transform into a mesh) I use MeshSplit but it doesn’t work, I tried this before with another object and it worked but I don’t know why it isn’t working anymore or what I am doing wrong

This is the result I get when I use the command

If someone could help me I would be grateful :frowning:
2408.3dm (3.2 MB)

1 Like

Mesh splitting is really quite poor in Rhino.
This isn’t new news and we are working on improving it.
This forum thread has a good discussion of the problem and suggested approaches:

1 Like

Thank you

Hi John,

Looks like the mesh operation problems are on the forum here every week or so. Hope this gets a high priority for improvements in V7.



The file you linked has already been split adding some unwanted mesh faces. One thing that sometimes will help is running splitdisjointedmesh before you run the meshsplit command. If you try to split disjointed meshes you can get some extra weird results. I moved the plane you had in here randomly and ran split on the large mesh piece and it worked.

I understand this isn’t where you wanted it split, but if you can go back to before you split it all as one piece you may get it to split properly separating the meshes first.

It is, and has been under active development for several months now.


Great to hear! I realize meshes will become very important for SubD in Rhino.
Thanks for the update John.


Thank you Ryan! I’ll do that!