Mesh split


I’m trying to split a complicated mesh. But Rhino and GH won’t do that.

(extractNonManifoldMeshEdges), (cullDegenerateMeshFaces), and (extractDuplicateMeshFaces) also don’t work.

Anyone clever brain can help? Thank you!

Try splitting it with a plane.

Hi David,

This is actually what I finally want from the 3/4 hollow sphere (from the other post that you replied). If it’s impossible to get rid of the seam I want to split the final baked model through the center to get the half without seam interruption, and then turn the sphere 180 degree to get the other half. But this crazy mesh just won’t split. I tried with a plane, a box, a cube…

Run it through Rhinos MeshRepair command and post what it says. Splits usually won’t work on meshes with issues. Maybe you have non-manifold faces, self intersecting faces, non-uniform normals, etc.

Hi Michael,

I can’t find mesh repair on my Rhino 5 for mac.
Here’s an object description. Did you mean this?

ID: 35fa9947-70f2-4a4d-9aa8-326b26af8f86 (1320119)
Layer name: Voronoi mesh
Render Material:
source = from layer
index = -1
Attribute UserData:
UserData ID: B5628CA9-82C4-4cae-9883-487B3E4AB28B
Plug-in: c8cda597-d957-4625-a4b3-a0b510fc30d4
description: Custom Render Mesh Parameters
saved in file: yes
copy count: 8
Valid mesh.
Open polygon mesh: 558130 vertices, 560064 polygons with normals
bounding box: (-0.494,-0.497,-0.266) to (0.497,0.498,0.493)

Nope, I mean this

It seems that Rhino 5 for mac doesn’t have mesh repair…

That is unfortunate :frowning:

Does this mesh use only planar faces (triangles or quads) or are they curved?

I have a script that splits all of my meshes that Rhino failed to split. But it is written for planar faces (triangles or quads).

You can try mesh iso splitting but you will get triangular faces.

For each vertex you have to put a weight could be X, Y or Z depending on the plane you want to cut.

Hi Terry,

The Object properties says:
Open polygon mesh: 558130 vertices, 560064 polygons with normals

I’m not sure if they are curved or not… It’s a mesh generated from GH.

You should upload your mesh so we can check it out.

Hi - as you have found out, mesh Booleans are not Rhino’s strongest side.
One work-around that you could try is to turn on the points of the mesh and then manually select the ones that are on one side of the trimming plane and simply delete those. Remember to copy the object in place and do the same with the points on the other side of the plane. There will be some work to do to create new triangles along the cut plane but at least it’s a way out…

If you upload the .obj file for your mesh I can try splitting it with my script which works much better than the Rhino Split Mesh command. Or if it is too big, you could post a link to it on Goggle Drive or something similar. Or send me a PM with the link if you want to limit access.

Your mesh is tiny compared to the 18M face mesh that I split with my script so it should have the capacity to deal with your mesh. But if your mesh has non-planar faces then this could be a problem.


Thanks! I think I need it to be smooth…

Hi Wim,

wow… it really get split! And as you said, to create the connection along the cut plane will be some work… And in my case almost impossible…

Thanks anyway!

Hi Michael,

The file is too big. Here’s a link to google drive.


Isosurface is able to cut (14.6 KB)

1 Like

I don’t understand, I just try with Mesh-> Boolean Split and it worked ?
And it gave 1 solid mesh

and one bad but that’s normal because of that (red parts)!

If the goal is symmetry you could try Pufferfish’s “Mirror Cut Mesh” component.