Materials won't change in render

Hi,

I’m struggling to change the material of my layers in my render. I’m able to select a material within the layer, but the new material doesn’t appear in the rendering. As you can see in the screenshot I took of my display, I’ve selected materials like “oak light” and “concrete light.” But the color icons beside the materials are white, and the materials don’t render. I’m pretty new to Rhino, so any advice would be appreciated. Thank you!

Gabe

Hi Gabe - if the object is a block, it may have its own materials set, or the object may have materials set per object and not per layer. Properties will tells you. If it is a block, you can BlockEdit and set the objects within the block to use material assignments ‘by parent’. Then it will follow the instance layer.
If it is neither of these please post an example file or send to tech@mcneel.com, with a link back to this topic in your comments.

-Pascal

Hi Pascal,

None of the objects seem to be blocks, so I don’t think BlockEdit is the solution. But I don’t have much experience with blocks, so I could be missing something. I’ve attached the file to this message so hopefully you can take a look. I was able to change the materials by using object properties for each individual object, but I’m still unable to change the materials by layer.

While you’re looking at the file, I wonder if you could help me with another small issue. Some of the edges of the objects are dashed, and I can’t figure out why. You will notice the dashed lines around parts of the bowling lanes and around the floor I put in. I crudely made the floor by importing a picture of slate tiles, making an array of the pictures, and using BooleanUnion and MergeAllCoplanarSurfaces-- I was hoping that the images would be joined into one seamless surface. But as you will see, there are still dashed lines on the floor demarcating the grid of separate images I’m working from. I went to display modes and tried decreasing the surface edge thickness to 0, but that didn’t work. I also tried changing Linetype but that didn’t work either. What do you think?

Thanks so much!

-Gabe

The Lanes Sculpture.3dm (2.0 MB)

Hi Gabe - it looks to me like it is all working - some of your objects have material assigned by object and do not pay attention to layer materials (you can see the assignments in Properties > Material tab) and, it looks like you may expect a parent layer material to propogate to child layers - it does not, you’ll need to set those per layer, though you can do it all at once with a muliple layer selection.
I’ll see if I can make the mapping better on some of these.

-Pascal