Materials still showing glare despite using non metal

I have set the material with the Shapediver advanced material component to toughness and non metal but the material still shows as glossy with bright highlights from the lighting.
How do I get a proper Matt finish?

If using a block colour is the problem, Is the answer to use a mapped material?

If I do map a bitmap for the material instead of a colour, does it add to the computation time?

Try increasing the roughness value to 1 to create a mat finish as in this model. Processing bitmaps adds to the computation time and the best practices on texturing are explained in this blog post.

Thank you Pavol. The image I sent was with the roughness setting set to 1 and metal to 0 and I still see the glare highlights.
I will take another look when back in the office.

There seems to be a bug when setting the roughness as internalised value. Can you set it with a slider to 1 in your Grasshopper definition and re-upload? You can then hide the parameter in ShapeDiver. Let me know if that fixed the issue.