Material Rendering Not Respecting Gloss & Reflective Settings

Custom material with 0% Gloss, 0% Reflectivity rendered with close to 100% gloss/reflectivity.


  1. Create object
  2. Create new custom material
  3. Assign “Gloss finish” to “0%”.
  4. Assign material to layer.

Expected Result:
Material should render as matte/flat.

All materials appear as 100% glossy and reflective. E.g. concrete and flat metals having a polished look.

I’ve tried various values for “Gloss finish” and while you set the value to “0%”, the display will update prior to “Apply” with the correct view. But after hitting “Apply”, the displayed gloss/reflectivity is set to something close to 100%.

Hi @rob.mackinnon,

I tried to reproduce this but I wasn’t able to. Are you able to repeat this from scratch? For example, you say you set Gloss finish to 0%, but for me it’s already set to 0% in a Custom material. Your screen shots also indicate there is more going on, for example your IOR is 0.01 and the material is shared by one or more other objects.

If you can repeat this from a new Rhino scene with just a simple sphere that would be helpful.

It would also help if you attached your model here so I can take a look at it.



I just re-ran this with Mac WIP 7.0.20252.12006, 2020-09-08.

As you can see, the material appears to have a reflectivity or gloss. In my OP, I tried messing with all of the dials (IOR, Gloss, Reflectivity, Transparency) to see if I could get any change. Even in the latest WIP the Gloss setting doesn’t seem to have any actual effect.

As you can see from the changing values, there is little/no change with “Gloss” on the main rendering. Mean while the material preview seems to work well after 1-2%, and jumps around under that value.

Material Preview Jank

Regardless of trial and error, and the index of refraction (IOR) being next to none, if you look at the image in the OP and the first image this post, with Reflectivity and Gloss both at 0% the object with a bump map is still reflective and glossy.

UI/UX Issue: having only a slider for these values makes it extremely difficult to match/change. Suggest a feature request for a value field to the left of the color swatch.

Hi @rob.mackinnon,

The file you have open with the spheres, do you think you could send it to us?

It would also be great if you could export your Rendered display mode. Go to RhinoWIP -> Preferences -> Display Modes -> Select Rendered -> Export Rendered display mode (button at the bottom of the dialog). Can you send us the exported display mode?

When you have exported it, press Restore Defaults in the top right. Does that help?

You can send us files privately through:


Sure thing …
Material Test.3dm (4.3 MB)

Rendered.ini (7.0 KB)