Brightness texture

Hello, how can I make a texture not affect the brightness? I apply a roughness map but it shines a lot in one area. I add the code of the material.


Hello @Jose_Antonio_Ordoñez,

can you maybe share the roughness map with me?

When you use a roughness map, the pixel values of that map are multiplied with the roughness value. In your case, the outcome might still be a low roughness value which may lead to these high intensity spots.

Additionally, you can have a look at your light setup. Maybe one of the directional lights is very bright, you may get better results by reducing the intensity of it and adding a brighter ambient light instead.

Hope this helps!

Cheers, Michael

Hello @MajorMeerkatThe3rd , I have already solved it, thank you very much.

hello @MajorMeerkatThe3rd, How can I make a material not be affected by light at all?

Hello @Jose_Antonio_Ordoñez, via the Api you have the option to use the MaterialUnlitData and assign it instead. Be aware though that you will not have all the properties available that you have in the standard material (because they need light to work correctly)