Match texture size of different mapping types

In short, I have some objects with custom (unwrapped) mapping that I want to have the same texture size as the box mapped objects of the model.

In my models I usually use box mapping of 2x2x2, so that it exports nicely to Twinmotion.
Since box mapping doesn’t create a continuous texture from side to side, for objects that have materials like stone, tiles etc that I want to be continuous, I use custom unwrap, but the texture size becomes random.

Is there a way to match the size without having to eyeball it?
I also have the same problem when matching surface mapping with box mapping.

Alternative question: Is there a way to use box mapping with continuous mapping? (similar to the attached image)

Thank you,

try MatchMapping

That should work nicely.

1 Like

MatchMapping removed the unwrapping seams and applied the box mapping of the other object.
My goal is to have an unwrapped texture, with the same texture size as the rest of the objects.
Thank you

Hello again,

I’m bumping, since I haven’t found yet any solution to my problem :melting_face:


Can you post a 3dm file with only a few box mapped and custom mapped objects in it that shows your issue? Also make sure a material with a texture is applied. You can select some objects and use the Export command to save the selection as it’s own 3dm file.

Hi Brian,

Please find the 3dm file on the link below.

3 same box mapped objects and 3 same unwrapped objects.
I’ve included in the file a problem that i’m getting when applying edge softening or displacement to unwrapped object.

Thank you,

Hi @ARID ,

Here’s a video clip on how I’d get the same texture size on multiple objects with different mapping types.

Regarding the edge softening issue, I think there’s a bug. I’ve filed . In the meantime, use the command ExtractRenderMesh and you will get a mesh object matching your edge softening settings. Note that the mesh modifiers use the render mesh settings as a starting point so you can customize how dense that mesh is in the Properties panel first too.