Massive performance problems


#1

Hello together,

I am running the newest Rhino 5 64bit Version on my brandnew:

Dell Persision T 7610
Intel Xeon CPU E5-2637 v2 @ 3.50GHz
32 GB Ram
Windows 7 64 bit
Nvidia Quadro K4000
Nvidia Tesla K20c

I have so heavy Performance Problems that it is nearly impossible for me to work with rhino.
file sizes about 150mb breaks down my orbit or zoom functions. to navigate through any model is nearly impossible.
I already tested everything. I reinstalled rhino a couple of times without any difference. all Benchmark test giving me high Performance results without any error.
A Dell technician were already here twice. He chanced the ram, the processor and the Mainboard. still the same Problem. Stange is, If I remove two of my four 8bg Ram sticks (run with 16 instead of 32gb) the Performance is a bit better, but still not as good as it should be.

I have absolutly no idea what to do now… are there any known compatibility Problems between my Hardware Setup and rhino5?

all other programs and Windows itself are working stabile and as fast as expected. but when I move any other program window over my rhino application it resuls in strange graphic Problems. the Windows are just ruckling and distorted. when I move them out of the rhino window again everything works fine immediately.

someone any idea?
Thank for your help…

Horst


(Willem Derks) #2

Hi Horst,

Can you describe the type of files you are working on?
File-size alone is no good indication of the type of objects you have in your file.
Do you have many blocks in your file, what type of other objects are in the problematic files?
Best would be to share a file that gives you trouble. Or describe a way to create a problematic file.

Are your graphic drivers up to date?

Just give as much info as you can, it will make finding possible causes easier.

-Willem


#3

Hi Willem,

870 surfaces, 25 meshes, 651 polysurfaces and 9500 curves. as I can see no blocks so far.
unfortunatelly I am not allowed to share some files public. I could try the create an file which brings me into that described Problems…

all my dirves are up to date…
thanks for your help


#4

You list 2 Nvidia products. I know that Rhino will work very well with the K4000 card. I’m not familiar with the “Tesla K20c”. Since all your other listed specs are not problematic I would look at this item. I did a quick Google search and it appears to be an accelerator. Can you shut that off and see how Rhino performs just using the K4000?

A 150Mb file is small. It shouldn’t be a problem.


#5

hi DanBayn,

the Tesla K20 Card is just in use for Cuda-able application. I use it for working with the “rhino live” render engine. it should not be a Problem.


#6

is there a way to Switch the tesla Card off by any Settings? or is the only way to remove the Card from my Computer?


(Willem Derks) #7

Hi Horst,

What GPU card is Rhino running on; go the Options page as pointed out in the image below and make sure the “Use accelerated hardware modes” is checked.
Can you send a screenshot of that dialog or state the information about Video Hardware and Driver information.

What plugins are you running, I assume Arion at least since you mention Rhino Live.
But maybe other plugins?
If you have graphic problems, is that when also using Rhino Live?
Can you disable the Arion plugin and see what performance you get than?

-Willem


#8

The K20 card does more or less the same GPU calculations as the K4000. There may be some sloppiness in the driver interactions that Dell/nVidia haven’t worked out yet. Since K4000 equipped machines (w/o K20) are known to work well with Rhino, in the interest of trying to isolate the issue, I would definitely try removing the K20 and it’s drivers temporarily to discover whether the issues disappear.


#9

Hi Willem,

as you can see in the attached Image below, the accelerated box checked.
I had the same idea as you and so after I reinstalled rhino I did not installed any plugins yet, but grasshopper.
but during the time I had arion installed I had no Performance Problems running rhino live. ist really just in the rhino viewport.


#10

OK…I will ask the IT to do that tomorrow and let you know what happens :wink:


#11

I setted up a qhick file where my Computer starts to ruckling the Orbit.
if you raise the value of the slider a bit it becomes nearly impossible to work on that file…
just 630 pt´s and one surface…performance.3dm (290.8 KB) performance.gh (8.0 KB)


#12

when I rotate around that little model I get the results you can see in the attached Image. the k4000 goes up to 25% what is OK I think, but the 1st CPU is almost around 100%…is that normal?


(Pascal Golay) #13

Hmmm- this is perfectly OK so far on my little MacBook Air/Intel 5000, so something else must be at work here. With the slider at 60 it’s still just fine.

-Pascal


#15

Hi
If your viewport is in wireframe view mode is it smooth to rotate?
ie. Is it only sluggish in shaded/renderer etc. modes when meshes are being rendered?
Have you tried lower render mesh settings.
Most of my models are about the same size/part numbers as you mention, and I am running a Quadro6000 + GTX660 with no problems with viewports.
Michael VS


(Steve Baer) #16

In order to eliminate possible causes of the problem, try baking your solution to a new 3dm file and reopen Rhino with that file (do not run grasshopper). Does the performance lag for the baked file?


#17

after baking the is no Performance lag by that example file…but the other files I talked about earlier having the same Problem without the use of grasshopper…