Performance issues with Rhino 5.0

rhino
performance

#1

Hello,

I was wondering if anyone could help, I’m having a few issues with performance with a brand new machine. The file size I’m using varies between 60mb and 500mb, however even on the smaller files the cursor jumps around the screen and just isn’t very smooth, it also lags when I zoom in and out (spikes of 1-2 seconds). The specs of my machine are:

I7 6800k (clocked at 3.4ghz, but with adaptive overclocking up to 4.0ghz when needed)
32gb Corsair Vengeance ddr4 2133mhz
Nvidia gtx 1080
ASUS x99-A II motherboard
Intel 600P 256GB m.2 nvme SSD

I’ve tried updating all drivers, including graphics/chipset and also done various tests on the SSD to make sure it’s performing as it should. I’ve also checked the performance of the computer while I’m using the files and it doesn’t look like it’s even breaking a sweat (nothing goes over 50% used). Is there something I’m missing on the settings that can make my life easier and the program run smoother? Any suggestions are greatly appreciated.


#2

Let’s make sure you’re using your Nvidia card. Make sure this is checked:


#3

Also, check your Nvidia settings. I make this change on all the computers here that run Rhino (more than 150!!):

I don’t know if there is an advantage between “Advanced Streaming” or “Dynamic streaming” but either one will be better than the base profile that is probably your current configuration.

Dan


#4

Many thanks for the response, I’ve double checked and hardware acceleration was ticked, but on my Nvidia driver I can’t see the ‘workstation app - dynamic streaming’ option. I’m currently using the ‘GeForce game ready driver Version - 375.95 Date - 18.11.2016’. I can see by the screenshot you’re using an older driver, could this be the reason I’m experiencing such lag?

Many thanks,


#5

I think that setting is only available on Quadro cards… --Mitch


#6

I see, that’s a shame. Going to get in touch directly to Nvidia to see if there’s anything I maybe missing out on with my gtx 1080.


#7

The GTX 1080 is kind of the “latest and greatest” thing from Nvidia and as a result may still be experiencing teething problems with all of the changes from prior GTX’s. You might want to see if there are other drivers besides the one you are using. Perhaps @jeff will have some thoughts and experiences to contribute.


#8

I just checked the Nvidia driver download page and it now shows an 11-28-2016 driver 376.09. Maybe this will improve things.


#9

Sorry, all we have is Quadro cards here so I wasn’t aware that what I suggested was unique to the Quadro.


#10

Don’t think its the graphics card.
I have a similar setup with a
6700k oc to 4.5
gtx 1080
I have smooth viewport performance on files up to 2gb in size.
Did you end up figuring out what happened?


(Pascal Golay) #11

@lyall - did you ever get this sorted out? If not, can you tell me if this lag is in all display modes, and does the lag show in any file, even a new one with say just a few boxes, or is it specific to some files?

thanks,

-Pascal