Make2D tends to omit Clipping Plane Intersections when Projecting to CPlane

If I setup a ClippingPlane for a Section, and then set up a custom Cplane that relates to the Clippingplane for the drawing, then project the Make2D to the CPlane, to keep the geometric references all inline, it often skips writing the ClippingPlaneIntersections layers. Occasionally creating a few random incomplete curves, just for kicks.
Is there anything I could be doing wrong about this? Or is it just a known issue?
It seems to be true in R6 and R7.
Sometimes I just have to use a custom parallel camera and the “View” option, and then reorient the results onto the manual CPlane.
I’ve tried the SectionTools plugin, but using it just to make up for the deficiencies of an already existing command is a little wonky.

I could provide screenshots if necessary.

Hello - my quick test works as expected - can you post a simple example?


Sorry, Pascal, I realized I need to be more considerate in which direction my Z-axis is pointing.
Which explains why going to a view fixed the problem.
It seemed to be an irregular problem, because I irregularly set my z-axis.

Thanks for checking.

Edit: SectionTools is surprisingly more useful than last time I checked it out too. :slight_smile: