Major Issue With Make2D V6 & V7

Hi Kyle, just checked, says ‘you are up to date on 6.24’ , I am getting the same stalls and then freezing on Mac V7 WIP too, but happy to try a new service release if available :+1:

I see that @Alexander_Jacobson’s reporting this on Windows, so this appears to not be Mac-specific.

@theoutside were you able to find a similar machine to @milezee’s that McNeel owns that we could reproduce this on? Since this appears to be not a Mac specific complaint, we’d probably need a sample file as well.

@dan @theoutside just tried with the 6.25 link you sent me Kyle, no different, make2d takes about 150 seconds, then when I try to move the 2d linework Rhino just seems to stall, then beachball, then have to force quit :weary:

@John_Brock will you test this on your 16" MBP 2019?
you seem to be the only one at mcneel with the same hardware- file is in the 1st post of this thread-

@dan, on it thanks!

1 Like

This is Mac specific @dan. The issue seems to be with newest MacBook Pro , I’m not seeing this with my old MacBook Pro late 2013. I think @Alexander_Jacobsondidnt didn’t realize this was under Mac category.

I’ll try it @theoutside

1 Like

@dan @John_Brock fyi, I just installed my old V5 Mac license on my machine, there is still a lag when selecting the Make2d linework, and a slight lag when moving it with the gumball, but it doesn’t beachball and then completely freeze, I know V6 code is different, so not sure if this is helpful

This sounds like what I’m getting on V6.

No problem here on my MBP 16,1

The Dwg file opened without error.
Make2D using the normal 4-views took about 25 seconds to do all 4 views.
I dragged the curves with Gumball over ad then up to get them away from the mesh chair.

No problems.
Version 6 (6.25.20059.16012, 2020-02-28)

uhmmm, not sure what I should do then, any ideas guys ? Thanks for testing John :+1:

It’s a huge problem if we can’t reproduce the problem here.
Hopefully Dan will have some tricky idea.

yes understood , John, when you imported that DWG did it come in at a tiny scale ? I had to rescale it x 1000 to get it to the right real world size ?

I Opened it directly (not import), and guessed millimeters for units.
It mostly filled the viewports.
I had to Zoom back to see the results of Make2D.

1 Like

ok, think we might be getting somewhere here, I have been importing, I have just tried straight open from the menu, imports fine, use Make2d, about 30 seconds (much faster than the 150 seconds), and then dragging with the Gumball works without freezing :+1: , so the issue is with importing
ps, still a touch laggy when dragging though, but kind of ok

that is good to know…what import options were you using before when it was bad? screen shot? we may need to poke at the dxf importer…

I think they are just the default settings, screenshot attached :+1:

What’s the tolerance in the file when you use import? Tolerance plays a big role when using make2d.

I can work with that.

  • Do you have any other models open?
  • What template are you using before you Import the DWG?
  • Are you using Wireframe display with Default settings?

When I get those details I’ll try to duplicate it.

Do you mean the tolerance in the file settings ? screenshot attached

Hi John, yes I open a new blank file, from a custom template of my own which I saved to the template folder (file attached) , yes I run the make2d from the top view in wireframe, and choose the 4 view option
Milezee Template.3dm (2.9 MB)