Rhino 6 Mac Performance Issues in 2d drawing


I am drawing 2d plans (architecture) in Rhino 6 Mac, which I recently upgraded.

I like the functionality, I like the workflow, I like the layout function.

But the software feels just laggy. Once you import some pdfs or some dwgs and start working (hatching, dimensioning etc.) the software starts to lag when I select, zoom or drag.
This happens in large files but also in very small ones (two or three floor plans and some section).

I use a mac mini 2016 and a macbook pro 15’’ 2017, both with the newest Catalina installation.


I’m also experiencing slowdowns while doing 2D work since I moved to V6 trial. In general V6 feels way more laggy on my system that V5. For example, using the attached file, in V6 if you try to randomly select and deselect the contour lines, and any line in particular, there are lots of beach ball moments, it’s not too long but there is definitely some lagginess. If I open the same file in V5 I don’t have any of those problems. It might be that my old MacBookPro late 2013 is not good enough for V6?

Edit: Try the other file posted in the next post.

Definitely there is something wrong with V6 here on my system. Try this more complex file, in V5 I can select all and move it without any problem, the same thing in V6 crashes Rhino…

I’ve had some serious lagging issues with Make2d geometry :thinking:

Hi @milezee, could you try my file, just select all and move it with your brand new MacBook Pro. Does it freeze your computer too? or it’s just mine? Thanks.

yep, highlight all, drag with gumball, beach ball of death, freezes, only way out is force quit :crazy_face::crazy_face:

Thanks a lot for testing. So there is a serious performance issue with V6 on Mac. I can move everything with no problem on V5.

1 Like

Ok, just tried in V5 Mac(above was done in V6), no problems, highlights and drags fine :+1:, so something wrong somewhere when using Rhino Mac V6

yep, as you know I had similar issue a few days back, but from importing and then generating Make2d, it was unusable, hopefully the powers that be will dig into this some more :+1:

Yes milezee, this is what is wrong with Rhino 6 mac.

It is not as bad on my computers, but lag in selecting, moving, rotating and so on is very annoying. It just feels a bit awkward to draw with this kind of latency.

1 Like

I tried your file.

It is not as bad as on your computers and my Rhino doesn’t crash. But it is laggy and unresponsive.
And as you said, it is not in any means a massive or complex file.

1 Like

Just checking it on Windows V6 as a comparison, selecting all and dragging (Gumball) works OK, the preview moves right away, then there’s about a 3 second lag before the command line becomes available again. There are almost 54K curves and 6K hatches in the scene…

(I have a GTX 980 Ti with 6Gb, not the most recent card, but still reasonably OK.)

1 Like

yep, definitely something funky going on with V6 on Mac then. I just tried on the V7 WIP too, same as V6, similar outcome, just freezes, sometimes completes but may take 60 seconds or more just to drag the geometry

Another question: Shouldn’t work hatch trimming in V6? Does it work on your versions?

I can confirm the unresponsivness when working with 2D drafting in R6 on mac. I can especially feel the latency when selecting annotation - text, dimensions etc. Working in Layouts with more then 50 sheets requires a looot of patience.

This is R7 feature as far as I know…but there are some scripts for this.

1 Like

I can live with that.
But they have to imporve responsiveness when drafting 2d drawings.

1 Like

I agree in that…I am just afraid it is a long time run…

I can report similar issues here as well… Working on some 2D drawings now and 90% of my time consists of just waiting for some command or edit to finish. Especially changing properties of lots of curves is extremely slow.

1 Like

Has anyone tried this in the V7 Mac WIP?
If anything major needs to be fixed, it isn’t likely to happen in V6.
Too risky.

Yes, and it’s the same as in V6. Try this file, select all entities and try to move it. If you do the same in V5 you will have no problems. Please, take a serious look at this because something is wrong with performance in both V6 and V7 for Mac.

1 Like