Major Issue With Make2D V6 & V7

I have a DWG file of a chair, downloaded from a suppliers website. Imports fine, nice model, but heavy on meshes, so Make2D so takes about 160 secs , after waiting for the 2d geometry to appear, I then try to drag it away slightly using the gumball. It just hangs Rhino, beach ball of death, unresponsive, have to force quit ! Have tried with both V6 & V7 WIP (both latest releases), same issue in both ??
Using a brand new 16" MBP , i9 CPU, 16GB RAM, Radeon Pro 5500M 4GB GPU
MI-1-D-3D.dwg (3.0 MB)

HI @milezee
Not seeing this here on a MacBook Pro Late 2013 with a Nvidia card. It takes less than 50 seconds to generate 2D projections and I can move it, the beach ball appears for a second but it goes away. I’ve tried to move it 10 times in a row with no problems.

Hi @jespizua , thanks for chipping in. Did you try/test with the DWG file I attached above ?
Also having major issues importing the same model but in 3ds format, It just hangs my machine, very concerning considering this is supposedly the latest kind of hardware, the 2014 MBP I just got rid of handled stuff like this better :weary::thinking:

Yes, I tried with the dwg file you posted. If you want to post the 3ds file I could give it a try.

Hi Jose, very worrying that Rhino is performing like this on a new machine ! I just tried to attach the 3ds file but it is not recognised as a file type to upload here on the discourse forum :weary:

Yeah, I’m also on the hunt of a new Mac system as my computers are quite dated, but after seeing how new systems are performing, I’m gonna wait a bit longer until I see some substancial improvements.

yeh there’s been some great improvements to Rhino in recent times, finding it difficult to do any project work right now with it tbh. Think I’ll do all my paid stuff in Vectorworks until some of this gets sorted :+1:

works great here on 6.24 with an older MBP-

please run the systeminfo command in rhino and post the results here-

just tested 6.25 on same MBP- works well there too-

Hi Kyle, thanks for checking, yes it worked fine on my 6 year old 2014 MBP, yet doesn’t play nicely at all on my new nearly £3k 16" MBP :weary:
Milezee System Info 02:04.txt (4.2 KB)

oof… that hurts…

@dan any thoughts here? His new machine should rip thru this task…

system info file attached above Kyle :point_up_2:

reading the WHOLE post is useful… >facepalm<

1 Like

I have also been receiving the beach ball of death, totally freezes rhino and my computer, the only way to recover the system is to power off my machine and start it up again.

I am unfortunately not able to share the Rhino file because it is sensitive to our business, but I received the error at least 12 times while working on it. It was whenever I tried to pan over a large part of the document that it happened. If I navigated around by staying zoomed in and panning only small areas at a time I was able to avoid it.

Happy to share the file via PM if someone wants to take a look.

please share you systeminfo as well, I’d like to compare it to milezee’s machine-

1 Like

It’s not even usable, just stalls then freezes completely, only way out is to force quit :thinking:

please run the systeminfo command inside rhino (in the rhino command line)

Ah, pardon. I’m still new around here.

Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Educational, build 2020-01-28
License details: Cloud Zoo. In use by: Alexander Jacobson ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: CPH-PC0063

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1080 (NVidia) Memory: 8GB, Driver date: 10-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.12

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.5.19140.1228
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

ok, in your case, please run windows update to make sure your machine is fully updated. you may need to run it several times to get them all updated.

then test…better? if not, then update your video card driver (it’s getting a bit old)

Use the custom install option, and then use the clean install option. restart your machine?

still not better?
help>check for updates in rhino, and update to the latest service release.

better? if not, kick your machine and swear.
(this is not necessary or actually recommended, but it’s what I do here)

in all seriousness, don’t do that,

still bad? let us know-

1 Like

@Milezee Can you check for updates and see if 6.25 is available to you yet? If not I can get you a link if you are up for trying the latest service release.