Maddening viewport behaivour

fullscreen
popup
viewport
4view

#1

hi,

when i click MMB to open my pop-up menu viewports acts strange as seen in the video. i have updated my video card drivers a week ago but this problem was there before that. any thoughts or suggestions @John_Brock ?

regards.

http://recordit.co/hliAN6xEB2


(John Brock) #2

This isn’t something I can help with but probably @stevebaer or @jeff can.
Can you please supply your display adapter and driver details?


(Steve Baer) #3

All I can recommend for that is to make sure you are using the latest service release of Rhino and update your video card drivers (which apparently you already did). Does this only happen in fullscreen?


#4

hi,

my display adapter is GTX 780, driver i am using is 376.53.

problem occurs when anything needs to be displayed, auto command completion, popups, match properties dialog box etc. it displays older instances of my rhino screen (4view to fullscreen, fullscreen to 4view, full to full…) even other rhino instances’ screen can be displayed time to time.

regards,

EDIT: i am sorry about the driver update, i thought i updated the driver but it seems like only installed a program, now i am installing 378.49 i will post the news


#5

hi,

driver is upto date now. i have restarted my pc but the problem still with me. :frowning:

regards.


(Steve Baer) #6

If you never go into fullscreen, do you see the problem?


#7

hi @stevebaer

yes. opened an old file (4view not fullscreen), suspicious of faulty geometry, just looked somewhere in perspective then pressed MMB for popup and rhino displayed the initial state of my perspective.


(Steve Baer) #8

Does the problem happen with every file? Can you repeat this bug by just drawing a sphere?


#9

Hi,

i updated the SR but the problem persisted, later a clean install fixed it. i can not test it now sorry :frowning:


#10

Hi,

different project same weirdness, it is happening but this time i guess the cause may be related to my second display. i dont always turn it on but when i did turn on it today rhino display did the thing again. (insert meme here :slight_smile: )

when it happened i have first closed rhino, re open the same file, same problem. closed rhino, turned down my second display, re open same file and no problem.

turned on my second display while a rhino instance is opened, draw a sphere, no problem ???

BUT

i closed my rhino instances (while the second display is turned on) and opened a new instance and when i draw a sphere the display weirdness is there.

does this help @stevebaer ?

PS: main display resolution is 2560x1600, second display resolution is 1600x1200


(Steve Baer) #12

It really sounds like a display driver bug or a case where the GPU is overtaxed with the second display attached. I haven’t seen this specific bug happen on another system and V5 has been out for quite a while. Sorry, but I don’t have any good suggestions on a fix.