Viewport bug


Hello, i downloaded rhino 6 trial, because i am planning to upgrade my rhino 4 but i faced an annoying bug. When i am clicking an object or a curve, viewports are acting strange, for example top view shows the front view etc. I searched the web for a possible solution, if i do not use accelerated graphics it works fine,so there is something wrong with my installed drivers, i updated them but nothing changed. i will post my video hardware and driver informations later.
My graphic card is the AMD R6 m345.
What would you advise me?

(Dale Fugier) #2

Hi @ilias,

Can you run the SystemInfo command and paste the results into a reply?

– Dale

(Nathan 'jesterKing' Letwory) #3

The described behaviour is pretty much the same as I see on our laptop. We tried to figure this out with Jeff, but no luck sofar. The laptop has an APU with integrated R5, and an HD 8xxx (don’t remember exact model now). @DavidEranen also tried to investigate, but we dropped the issue since trying to install latest gpu drivers nearly killed the laptop.


Hello, i uploaded the info you asked and i also uploaded a picture that shows exactly what is happening.
Everytime i am selecting the A object i am getting that result, in a different way everytime of course.
Front view shows prespective view and prespective shows the top view. Sometimes the A object turns yellow in only 2 of the 4 viewports etc.

(Nathan 'jesterKing' Letwory) #5

@ilias, The SystemInfo command intended is the one you type into Rhino command-line. You can also find it in the Help menu of Rhino as the entry System Info

(Nathan 'jesterKing' Letwory) #6

Actually, I have now applied the latest available Windows 10 updates. I also installed the latest WIP. I have now a properly working WIP.

The output of SystemInfo is:

Rhino 6 SR0 2017-10-12 (Rhino WIP, 6.0.17285.15051, Git hash:master @ 0f4068a5344cd644c7b83cf77e36446773e97a27)

Windows 10.0 SR0.0 or greater (Physical RAM: 6.9Gb)

AMD Radeon HD 8500M (OpenGL ver:4.5.13397 Compatibility Profile Context 15.200.1055.0)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Anti-alias mode: 2x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  Vendor Name: ATI Technologies Inc.
  Render version: 4.5
  Shading Language: 4.40
  Driver Date: NA
  Driver Version: NA
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 2 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp	"Commands"	
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp	"Rhino Render"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp	"Cycles for Rhino"	
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp	"Displacement"	

My GPU driver is pretty old, but I am not going to attempt to update it - this laptop has given quite a bit of trouble trying that. The driver is dated 6-7-2015 , and its version is 15.200.1055.0. The laptop runs Rhino WIP properly now ,so I won’t bother updating GPU driver for now.


@nathanletwory I cant’t find it.


(Nathan 'jesterKing' Letwory) #8

@ilias, can you attach a screenshot with the splash screen, and one where also the title bar of Rhino window is showing?



p.s. note that the System Information entry should exist in the Help menu



As you can see system information does not exist at all.

These are my video and driver information.

(Nathan 'jesterKing' Letwory) #10

That is because you’re using the Rhino 5 trial. We tought you were using the Rhino WIP, as that is the upcoming Rhino 6. Beyond perhaps ensuring your Windows and display adapter drivers are up to date I don’t know what to suggest. For Rhino 5 there won’t be any further service releases, the next is the Rhino 6.

I don’t know if or how you could try the WIP, probably best is to contact the good people of to ask for assistance in that matter.


Okay, i appreciate your effort to help me out but what about the viewport bug?

(Nathan 'jesterKing' Letwory) #12

Any fix for that will go in Rhino 6. But as I said, you can try updating your Windows making sure it is the most up to date, as well as ensuring the drivers for your GPU are all good. Beyond that I don’t think we can do much.