Glitch when typing M for Move after cut and paste

Here’s a new one for me in V6. When I cut and paste something, then immediately type “M” to move something, I’ve been noticing that the M is totally unresponsive until I click in the command line. I just realized where all of those repeated Ms were going to as I sat there hitting the key over and over. It seems as though Rhino is picking one of at least a few text boxes and just starting to write there instead of where it should be. Note the screenshot.


Where is your pointer when you Paste/Ctrl+V?
What are you cutting and pasting?

The cursor is over the window I’m working in (immediately following the selection of whatever it is I’m going to cut/copy). It’ll do it when cutting individual curves, surfaces or polysurfaces. I haven’t tried anything beyond that.

I just tried copy/paste (Ctrl+C/Ctrl+V) between two Rhino sessions (I copied a box), then typed “M” and the Rhino I was in had “focus” so the M went to the Command line as expected.

A second try copying a layer name and renaming a new layer, and the M was added to the layer name as that tool had “focus”.

That’s different from what I’m seeing. With a single instance of Rhino running, I’ll click on a piece of geometry, hit Ctrl+C or Ctrl+X, then M. At this point, rather than initiating the Move command, it’s now typing M (or whatever else) in my materials or environments window. I’ve not clicked on, moused over, or done anything else directly with either. Additionally, I’ve never experienced this behavior in V5 running through the same sequence of commands in the same way.

I’m running 6.6 (the SR candidate).
Are you running a Spacemouse or some other input device?

I do have a Cintiq hooked up, but the pen has been sitting in its little cup all day. I’m not sure how it would have been having an effect, but who knows? :smiley:

You could try disconnecting it to see if the behavior changes.
I’m running pretty bare here.

No dice. I pulled the windows that were displayed on it onto the main display, unplugged it, and the behavior remained. V5 still doesn’t exhibit the behavior.

Hello - is this on PC hardware or mac hardware running Windows? I ask because I occasionally see this need to click in the command line to get action on my mac that is bootcamped running windows running V6, and never on my PC.


Hi Pascal, it’s a Dell Windows laptop. I’ve got an eval version of Rhino 6. The only other weird thing I can think of is that I’ve got my licensed version of Rhino 5 installed also, but it doesn’t seem to be causing any other issues (at least not that I’ve found so far).

I’m getting the same behavior (v6.8.18205) . Whenever I ctrl+v in the viewport (both model space and layout), the focus moves to the text box for the first material’s name.

I’m also running a Dell desktop (Precision 5820 Tower). I wonder if there’s some dell software that’s interfering with text focus?

FWIW I can redo this with 6.6.18177.16151.

To reproduce I

  • create a torus
  • create several materials in the material editor
  • ensure material editor is the panel that is open
  • select the torus
  • CTRL+C
  • CTRL+V
  • M - several times
  • Notice that at this point the mouse cursor changes to a small black square
  • command-line stays empty
  • click in viewport
  • notice update of first material in material editor with lots of ‘m’-characters added at the begin of the name


there is more to this: with last material selected, do the objects select, copy and paste, then type M (mouse cursor changes to black square), then click. Note that the first material now reads the name of the last material with as many m's prepended as you typed.


Here an animated GIF with the glitch:

note: interestingly enough the black square mouse cursor isn’t visible in the GIF - it shows when in the GIF the cursor briefly disappears while trying to write the m-character.


arguably better GIF. The input glitch is for any keyboard input, here I type ExtractRenderMesh after the copy&paste, followed by ENTER. The enter appears to do the same as the mouse click in earlier reports/tests

This is most likely to be a bug in the Material Editor itself, which is my code. I’ll look into it.


I have filed a bug report for this. It is definitely a bug in the Material Editor.


I have just committed a fix for this. It should appear in the next service release which I believe is SR9 on August 28th. (Sorry, my previous version estimate was wrong)

1 Like