Mac v6 vs v5 Line Display Quality on MacPro


On the same Mac Pro 6,1, I see a marked difference in wireframe line quality between v6 and v5 with antialiasing set to - None - on both v6 and v5.

Surface edges do not seem to be affected in v6. Bumping up antialiasing in v6 does ‘smooth’ a bit, but still way off and undesirable to use compared to v5 set to - None. Not sure if the screenshots do it justice, but again, the difference is stark between 5 and 6 on this box and I’m not sure why.

FWIW - v6 wireframe line quality looks great on a iMac 17,1 - issue does not exist. Both the Pro and iMac have 10.13.6.

Thoughts? Thanks!

v6 - MacPro

v5 - same MacPro

Rhino 6 SR15 2019-3-5 (Public Build, 6.15.19064.12046, Git hash:master @ a4ab7d397ae9c486eb664fecbc8bcb43592bd2f1)
License type: Beta, build 2019-03-05
License details: Cloud Zoo. In use by: Richard ()
Expires on: 2019-04-19

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G5019) (Physical RAM: 32Gb)
Mac Model Identifier: MacPro6,1
Machine name: Mac Pro
Language: en-US (MacOS default)

AMD Radeon HD - FirePro D500 OpenGL Engine (OpenGL ver:4.1 ATI-1.68.21)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB
Graphics: AMD FirePro D500
Displays: BenQ LCD (216dpi 2x)

Graphics processors
AMD FirePro D500 (3072 MB)
AMD FirePro D500 (3072 MB)
BenQ LCD (3008 x 1692 @ 60 Hz)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Realtek: USB3.0 Card Reader
LaCie: Rugged USB3-FW
OWC: Elite mini USB3
GN Netcom A/S: Jabra EVOLVE LINK
GenesysLogic: USB2.0 Hub

Bluetooth devices
Cambridge Silicon Radio: MX1000 Mouse
Broadcom: Magic Keyboard

Third party kernel extensions
com.paragon-software.kext.VDMounter (526.1) DEA8787E-5CCC-31F8-9730-B5E58A4C15D1
org.virtualbox.kext.VBoxDrv (5.0.10) 23DD0853-7210-3AF2-85FA-1C7FF8F7D1BF
org.virtualbox.kext.VBoxUSB (5.0.10) C5D33477-F93D-36AD-8748-1EB1105FB93A
org.virtualbox.kext.VBoxNetFlt (5.0.10) E5ABC825-5396-34A7-9B63-3A38E9142EEC
org.virtualbox.kext.VBoxNetAdp (5.0.10) BEFC91DC-800F-3F16-8388-50584243FB30
com.paloaltonetworks.kext.pangpd (1.0.0) 2EB7232F-AC35-3CB5-81B3-D81783A18EEF

Third party plugins

Rhino plugins
/Applications/ “PanelingTools” 6.15.19064.1002
/Applications/ “IronPython” 6.15.19064.12046
/Applications/ “Commands” 6.15.19064.12046
/Applications/ “Grasshopper” 6.15.19064.12046
/Applications/ “Displacement” 6.15.19064.1002
/Applications/ “Rhino Render” 6.15.19064.1002
/Applications/ “RDK_EtoUI” 6.15.19064.12046
/Applications/ “RhinoCycles” 6.15.19064.12046
/Applications/ “Snapshots” 6.15.19064.1002
/Applications/ “Renderer Development Kit” 6.15.19064.1002

Thanks for reporting this @ec2638. Unfortunately, this is one of the few machines we don’t have at McNeel. I’m going to do a search of our machines to see if we have one with the same GPU however (or close enough to match). We don’t have any Macs with a similar card.

@stevebaer any ideas here?

Wires are drawn completely different in V6 than V5. We have users who have also complained about this on Window V6. This is just one of those things that we keep trying to improve, but I don’t really know how much better it is going to get in the near term.

Great! Thanks for any efforts. Existing 6,1 Mac Pros still have lots of life in them.

What’s peculiar to a lay non-developer is: why would surface edges display fine in Wireframe, Shaded, Ghosted, but not wires?

Furthermore, in Pen mode, wires draw sharp and clean similar to V5! Why?

It looks like a thickness issue. We may have to bump the minimum thickness up a little bit on Mac.

1 Like

Issue solved!

OK, I’m finally using v6 in earnest now, rather than playing, and therefore motivated to look ‘within’ for a solution to this visual annoyance/flaw rather than externally. I apologize if I was annoying about it! Realized scope was limited to a small number of rigs.

Solved on my one rig that had the issue. (MacPro6,1 32" 4K display). Peculiar (to me) that v5 never had, yet v6, with same Rhino display modes and OS display settings, did have, but who cares…

As @stevebaer suggested, simply need to bump up all display modes where wireframes, curves, isocurves defaulted to 1 - change to 2, and all 2s (e.g. surface edges) to 3s. Bingo!

FWIW - the 32" 4k was also always set Scaled in Display/Sys Pref to the middle setting - looks like 3008 x 1692. Setting to "Default for Display (3480 x 2160) helped significantly with display modes set to 1, but then I can’t see anything in general in that res. And 5K iMacs never has the issue in any default display modes or scaled display resolutions. (any “1” setting)